Diablo® III

New Stuttering Workaround!

Posts: 3
this is some thing i read on toms hardware
Micro-Stuttering And GPU Scaling In CrossFire And SLI
http://www.tomshardware.com/reviews/radeon-geforce-stutter-crossfire,2995.html
Reply Quote
Nice, thanks for the tip. I have 2 ssds in raid and this fixed my stutter problem. The stutter I saw was similar to the sli stutters of the past. The background would stutter very slightly with no change in fps, I have seen this issue in many games including WoW over the past 7 years. I first noticed it in vanilla wow and again after I built a tri-sli system with a fourth gpu working as a physx processor back in 2008. What many of you are describing are not micro-stutters and as such this fix may not be very helpful to you.

I have my laptop set up to enhance the aa with EQAA and I have enabled morphological filtering (wahtever that is) and the game runs great. I never dip below 50fps and usually sit between 55 and 60 with everything maxed. If you are having problems with the aa maybe you need a better gpu or cpu as aa is cpu intensive I believe.

P.S: Weird thing, I stopped playing after the first week I had the game 'cause I went to wow for mop. Whenn I came back my laptop ran the game better then before. When I quit I was pulling maybe 45 fps avg with all settings maxed and 60 flat with shadows turned down a notch. When I came back I set the shadows to max and the game sits at 60 and never dips below 50.
Edited by JNM#1209 on 11/27/2012 8:39 AM PST
Reply Quote
??????????????????????????????????????
nothing works.
It's not our end, it's yours.


If it is on Blizzards end then wouldn't we all be impacted by this issue? I saw a post by a guy with the same computer as me, mine has 8GB more memory than his, and he was adamant in his belief that the issue was on Blizzards end. If the problem is with Blizzards software then wouldn't I suffer the same issues as he? My guess is that many of you don't have AV and maybe you look at dirty movies online or DL illegally.
Edited by JNM#1209 on 11/27/2012 8:52 AM PST
Reply Quote
Try this: http://us.battle.net/d3/en/forum/topic/7199402147
Worked pretty well for me.
Reply Quote
thank you so much!!!! im forever greatfull :)
Reply Quote
88 Tauren Druid
9355
Posts: 13
Well.... i never tough something so simple would make me so happy!
Reply Quote
Thought I would post this fix on any threads that were about the stuttering issue becuase it was driving me absolutely insane!!! After trying everything I finally figured it out thanks to someone who posted something several months ago that turned on a lightbulb in my head...

His solution was this:

"I simply turned off real time protection on my anti virus software. (microsoft security essentials)."

Basically whenever the SDD or HDD was being accessed, real time protection was scanning them for viruses etc, and thus the game files were being accessed multiple times whilst they were trying to load in game.

Such a simple fix. Game is now 100% smooth with no stuttering at all.


I'm pretty sure this was my problem as well! I didn't have the exact same fix but basically I installed the game on my C:/ drive instead of my alternate internal E:/ drive I use for most Applications and now the stuttering is gone.

Wierd thing is I used to have it on that same drive and had no problems, all of a sudden when I come back to play again it was stuttering like crazy! So McAfee must have been trying to scan the files or something on the External hard drive as they were being accessed.

Regardless I re-intalled it on the C:/ drive and its fixed.
Reply Quote
Posts: 67
How about you guys release patchs that don't need your customers to then go and PATCH YOUR PATCH I swear to god every patch it gets worse and worse hire experience people seriously getting out of hand here. hell I know effin 16 year olds who can patch and do better work then you *beepers* really is sad I have to say
Reply Quote
This helped me with the micro stutter. I got an SSD and it got rid of the loading stutter.
Reply Quote
The stuttering I get is only when first loading textures. like first time using a skill since PC was turned on causes a short delay/chop. After that initial loading of any textures it goes away, as long as PC remains on.
Reply Quote
Blizz, thanks. this worked for me
was getting rubberbanded every 4 sec or so.
much thanks for giving attention to your customers.
Reply Quote
It didn't work for me either my problem seems to happen with all my settings ramped up and shadows on "smooth" now i'm sorry but my GTX 460 1GB ran my Diablo 3 Game perfect on smooth shadows so i think its some sort of incompatibility with settings on the highest. And with the card i have now a GTX 660m 2GB its should be running it better...
Reply Quote
This issue has gotten worse for me. I have been playing since launch with very little stuttering, but now the game will actually freeze from time to time (esp bad on first load).

I have a i5-2500k
GTX 570
Crucial M4 SSD
8gb DDR3 1600 ram.

Almost impossible to play this game with witch doctors for me. No clue why. Seems to be huge memory leaks. I ran tests on my RAM etc and nothing. I play Farcry 3 at max details... seems to me that this issue is just poor coding.
Reply Quote
this is a greate fix!
Reply Quote
fixed load times but thats about it
Reply Quote
While the following isn't guaranteed to resolve all stutter symptoms on all systems, we have seen significant improvements on several computers using this method. This workaround involves partially disabling Windows Drive Indexing, a tool that speeds up Windows searches.

Disable Drive Indexing

1. Click Start
2. Click Computer*
3. Right Click your Hard Drive (typically C:) and select Properties
4. Select the General tab
5. Uncheck Allow files on this drive to have contents indexed...**
6. Click Apply
7. Select Apply changes to drive C:\ only
8. Click Ok, and then Ok again
9. Load up Diablo III and see if your performance has improved!

* = My Computer on Windows XP
** = Allow Indexing Service to index... on Windows XP

Turning off indexing to the "drive only" will still enable your Windows' searches to be quick. If you still have stuttering after this workaround, you may wish to experiment with turning off indexing to subfolders and files as well. Once you've turned indexing off for everything, the option will change to one that lets you re-enable it if need be.

In the meanwhile, I'll pass this information on to the devs so that hopefully more changes can be made on our end to reduce stuttering. Thank you!


My brother and I just tried this and it fixes our problem 100%. He had the stuttering just every now and then while i had it all the time. After the game loads its best if u sit in town the first 30 secs then everythings fine.

Trust windows to do sneaky things in the background!

BTW if you want FPS displayed onscreen just press CTRL+R (displayed bottom right corner under friends)
Reply Quote
This did nothing for stuttering.I noticed when i fisrt cranked this game up it did not stutter and game play was awesume.
Edited by JacobsHell#1185 on 1/7/2013 9:45 AM PST
Reply Quote
Has this helped alot?
Reply Quote
Once you check it back it goes back?
Reply Quote
yeah the checkbox immediately turns back on, this doesn't work
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]