Diablo® III

Modifying the D3Prefer.txt Quadrupled my FPS!

Wow, I did not realize how two changes could DRASTICALLY chance my gameplay performance. Before I was playing on low settings but with severe lag and rubberbanding, I was going to stop playing Diablo, because the game was only playable for the first two acts.

1) Go to Applications --> Utilities --> Terminal

2) Open Terminal by going to Applications then Utilities the Terminal

Then type this :

open ~/Library/Application\ Support/Blizzard/Diablo\ III

And press return.

3)
Change the following:
-DisableTrilinearFiltering "1" (from 0 to 1)
- HardwareClass "1" (from 0 to 1)
-ChannelsToUse "16" (from 32 to 16)

I can now play on maximum settings (including shadows!) with 30+ FPS in all zones in the game!

Let me know if it works as well for you!
Reply Quote
Support Forum Agent
Cool!

You can easily open this in TextEdit by going to the ~/Library/Application Support/Blizzard/Diablo III directory.

Question though:
07/02/2012 11:18 AMPosted by Infineon
- HardwareClass "1" (from 0 to 1)

This means you were unsupported. What is your graphics card?
Reply Quote
NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3427
Displays:
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected
Reply Quote
Cool!

You can easily open this in TextEdit by going to the ~/Library/Application Support/Blizzard/Diablo III directory.

Question though:
- HardwareClass "1" (from 0 to 1)

This means you were unsupported. What is your graphics card?


Edit: I did not change my hardware class from 0 to 1. It was already set to 1. This was in original post I got the info from, so I included it in the original post.
Reply Quote
91 Dwarf Paladin
10220
Did this on my 21" iMac, which has been having lag spikes/slowdowns and rubber banding since 1.03. Smooth as butter. All I changed was the sound channel to 16 and Disable Trilinear filtering to 1. Didn't change HardwareClass, as it was not 0.
Reply Quote
Support Forum Agent
Thanks for the feedback on this.
Reply Quote
I had a considerable FPS spike since 1.0.3, but nevertheless I'm gonna try this. I have the 9400M too, running on Snow Leopard. I am actually running about 15-25 FPS in most zones, but with everything on low. Do you think this will help me too? I can't try it till the maintenance is over lol
Reply Quote
Wow, I did not realize how two changes could DRASTICALLY chance my gameplay performance. Before I was playing on low settings but with severe lag and rubberbanding, I was going to stop playing Diablo, because the game was only playable for the first two acts.

1) Go to Applications --> Utilities --> Terminal

2) Open Terminal by going to Applications then Utilities the Terminal

Then type this :

open ~/Library/Application\ Support/Blizzard/Diablo\ III

And press return.

3)
Change the following:
-DisableTrilinearFiltering "1" (from 0 to 1)
- HardwareClass "1" (from 0 to 1)
-ChannelsToUse "16" (from 32 to 16)

I can now play on maximum settings (including shadows!) with 30+ FPS in all zones in the game!

Let me know if it works as well for you!


What are the disadvantages to performing these steps?
Reply Quote
i heard it is illegal to change anything inside the file...so hmmm
Reply Quote
MVP - Technical Support
View profile
07/10/2012 07:36 PMPosted by Sirrus
i heard it is illegal to change anything inside the file...so hmmm

that's nonsense. It's fine to change that file since it's just config. It's against EULA to modify game DATA files but that's not a game file that's a pref file.

Sound cannels can use a lot of cpu so setting it lower can help but also reduces how many sounds can play at same time before sound effects are ignored. you may hear less vibrant sound experience at 16 channels vs 32, but it shouldn't be too bad.
Reply Quote
I was just checking the strings:

-DisableTrilinearFiltering "1" (from 0 to 1)
- HardwareClass "1" (from 0 to 1)
-ChannelsToUse "16" (from 32 to 16)

I have had some stuttering problems and sorta poor FPS, still around 20+ to perhaps 40ish, so thats not the worst, but with my configuration, it should be a lot better imo.

My specs are:

iMac
i5 2.8
12gb ddr3
ATI Radeon HD 5750

And the game haven't been running smooth at anytime, but its defiantly playable.

So, i checked the strings as i mentioned, and noticed that:

- HardwareClass "1" (from 0 to 1) - mine was on "4" ? Thats sorta weird i guess? 4 isn't even a valid number if we are talking binaries (1=true 0=false in this case)

I disabled triliinear filtering now but left sound channels on 128 in my case (will try and change it in game in case of any problems)

I can't test it yet because of maintenance, but I'm looking forward to it.

It was the number 4 that stumbled me.

And no, its not illegal to customize the preferences :-p
Edited by Splintrix#2859 on 7/10/2012 10:56 PM PDT
Reply Quote
- Technical Support
90 Human Priest
6220
07/10/2012 08:00 PMPosted by MysticalOS
i heard it is illegal to change anything inside the file...so hmmm

that's nonsense. It's fine to change that file since it's just config. It's against EULA to modify game DATA files but that's not a game file that's a pref file.

Sound cannels can use a lot of cpu so setting it lower can help but also reduces how many sounds can play at same time before sound effects are ignored. you may hear less vibrant sound experience at 16 channels vs 32, but it shouldn't be too bad.


Heh, while the sounds in this game for spells and abilities are far superior to WoW's sounds (they really are!), they get repetitive. This is one area I'd be more than happy to accomodate loss of sound for better framerates.

Funny thing is my framerate drops are when breakables "explode", and for about five seconds after they're done "moving" about the screen. Then it returns to normal. Wonder if the sound channels are getting that saturated...
Reply Quote
can anyone confirm that this is working?
i started playing d3 on bootcamp as performance was just awful on mac!
have the 9400m as well and 8 gigs of ram. i'm on 10.7.4 (lion)

thanks
Reply Quote
I haven't tested it for more than a few minutes, but I think the key is the trilinear filtering. I didn't notice any substantial CPU changes (or smoothness in game related to changing the sound channels. The game did look a bit fuzzier.

Given that FPS reporting have been broken for a while now, I'm curious to understand the OP stating his frame rate has quadrupled. What did you use to measure?

Until we get that fixed, I'm not sure any exact measurements can be done, but it certainly makes sense that turning off graphics effects speeds things up. I don't remember seeing the filtering in game, but I may have just missed it.
Reply Quote
07/10/2012 10:53 PMPosted by Splintrix
- HardwareClass "1" (from 0 to 1) - mine was on "4" ? Thats sorta weird i guess? 4 isn't even a valid number if we are talking binaries (1=true 0=false in this case)

'Hardware Class' is not a boolean value and is something like a graphical quality level, from 1 being the lowest (actually 0 if your hardware is not supported) and 5 (or 4?) being the highest.
Edited by Deimos#2660 on 7/11/2012 9:18 AM PDT
Reply Quote
07/11/2012 09:17 AMPosted by Deimos
- HardwareClass "1" (from 0 to 1) - mine was on "4" ? Thats sorta weird i guess? 4 isn't even a valid number if we are talking binaries (1=true 0=false in this case)

'Hardware Class' is not a boolean value and is something like a graphical quality level, from 1 being the lowest (actually 0 if your hardware is not supported) and 5 (or 4?) being the highest.


Mine was/is 6 when I open this file...

I left it at 6, but disabled trilinear filtering and have noticed a great improvement.
Reply Quote
FWIW, none of those changes made any improvement for me. I have:

2.7 GHz Early 2011 MBP
8 GB RAM
13" screen at 1280 X 800 resolution in game and overall
Intel HD 3000 chipset
OS X 10.7.4

I get about 20-25 FPS on average, I think, and though of course faster would be nicer, I'm happy with that. The only thing I've found has a significant impact on speed is turning shadows on. I have them off (and I'm happy with that, too).

I guess trilinear filtering is not available with my chipset?
Edited by Sarahswati#1566 on 7/11/2012 2:46 PM PDT
Reply Quote
Is there a faq or how-to anywhere on what all these settings do? I mean, it feels kinda cryptic.
Reply Quote
Other than the tooltips that pop up when you mouse over the options?
Reply Quote
07/13/2012 02:36 PMPosted by Sarahswati
Other than the tooltips that pop up when you mouse over the options?


There is no tooltip for disabling "trilinear filtering". What do you think he/she meant? Don't be a troll.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]