Diablo® III

Stops at initializing.

When I woke up this morning, there was a message from my launcher saying there is a very important update I need to patch and there are a few problems now.

1) Won't stop asking for my permission to run
and
2) Won't stop initializing

OSX: Lion
15-inch MBP (late 2011)
Reply Quote
Having Same issue
OSX Lion 13 inch 2011
Reply Quote
Support Forum Agent
Try this and see if it helps.

Repair Permissions via Disk Utility
    1. Navigate to /Applications/Utilities/ and open Disk Utility.
    2. Select the hard drive the game is installed on.
    3. Select the First Aid option.
    4. Click on the Repair Disk Permissions button.

Resetting permissions on the Diablo III folder
    1. Select the Diablo III folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items
Reply Quote
Bump,

I get the same issue. Woke up this morning... same thing.

Brand new iMac, quad core i5, 12g ram, 500g HDD (June 2012)...

Every time i run from the launcher OR the game file, i get a pop up window saying "Agent wants to make changes. Type your password to allow this". So i type my admin password and the launcher goes to "Initializing" and it just gets stuck there...

I can't hit the play button, theres no loading % or anything... just a blank launcher that says "Initializing"

Ive tried running from both the launcher and the game file, ive tried repairing disk permissions, and deleting the "Updates" folder and also leaving the launcher for 15+ minutes to see if anything happens after a while. Still does the same thing...

PLEASE HELP!!!

I dont want to have to go back to D2 :P

EDIT: Also tried checking the folder permissions... they're all set to "Read & Write"
Edited by Filterkat#1851 on 7/30/2012 6:04 PM PDT
Reply Quote
Hi Machkhan

When you say Command + / what is that "/" is it an L or 1
Reply Quote
Ok done. Anyway if prompted just press Cancel
Reply Quote
Lousy, its Command + i

Yeah just an update... it finally worked... when prompted for the admin password, hit cancel instead of typing youre password and it worked for me...
Reply Quote
Lousy, its Command + i

Yeah just an update... it finally worked... when prompted for the admin password, hit cancel instead of typing youre password and it worked for me...


This worked for me. Repaired permissions, deleted battle.net folder, set diablo 3 folder permissions with no luck. Canceling admin elevation made it work.

This only happened on one of 3 macs, other 2 were fine.

I vaugely remember this happening a long time ago with a WoW patch back when I played that, where you had to cancel the permission elevation to make it work... very very strange, thanks Squarepusher!
Reply Quote
90 Human Warlock
13995
Had this same issue. Lion 10.7.4, mac mini server, stuck on initializing.

The only thing that fixed it was starting the game from the game file and denying it admin access. None of the other steps worked.
Reply Quote
Same problem, cancel worked! Thanks man. This launcher has really had troubles lately.
Reply Quote
Same problem as well.
I had the dialog box pop up twice, where I put in my admin password. Now it won't prompt any more and my permissions are already set correct.

Thanks for the update, real nice.
Reply Quote
Same problem (on Mac Pro), so upvoting. I was about to try the permissions thing, but then I saw the canceling-permissions fix, and figured that was easier to try. Worked.
Reply Quote
I've just tried both of these and am still having the same problem. Suggestions?

EDIT: Okay, so I wasn't getting the admin dialog after repairing permissions. I went to the D3 folder again and changed the permissions to read only and then changed it BACK to read & write, and that gave me the admin dialog when I opened the launcher. I clicked cancel and now it's working fine! Thanks, guys!
Edited by Cazunaitha#1828 on 7/30/2012 6:53 PM PDT
Reply Quote
cancel worked for me as well, thanks all
Reply Quote
Confirmed.

Just hit cancel my dawgs.
Reply Quote
Running Mountain Lion. Same thing happened today. After the first failed attempt and a force quit, the system wasn't asking for the password anymore and updater was stuck on "initializing". Followed Machkhan's instructions, and pressed cancel on password request.

Works fine now. Off the top of my head, I can think of 2 other players who simply do not have the capability to fix the problem, let alone bother to look-up a solution online. Likely, they'll just give up playing the game. What's up Blizzard? Don't you test your updates?
Reply Quote
Same problem here. I've gone through the threads and have tried to find a solution with no luck. I'm on Mac Snow Leopard.
Reply Quote
i got this problem this mornin as well but had to go. cant wait to get home to fix this bs issue. its real annoying
Reply Quote
23 Gnome Mage
0
If you don't hit cancel the first time you are asked, it seems the launcher will never ask you that again. In that case do what they said above, launch Diablo III from the application folder without using the launcher, then click cancel when it asks you for admin password.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]