Diablo® III

Stops at initializing.

For some reason I didn't see all these comments when I first posted. I rebooted and relaunched and hit cancel when it asked for a password and it worked. whew.
Reply Quote
After the 'cancel' trick, it shows that I have 4.21GB left to download, but my progress is shown as 0%. The 'Play' button is grayed out. I was playing on a partial installation earlier today. This update really messed things up.
Reply Quote
It finally worked for me when I opened the actual Diablo 3 program file in the Diablo 3 folder. I also hit cancel instead of giving permissions. I can't find who said to do that on this thread, but it works and THANK YOU.

Don't know why Blues can't help us figure this out and we always have to rely on each other to get the proper info.
Reply Quote
Try this and see if it helps.
Resetting permissions on the Diablo III folder
    1. Select the Diablo III folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items


I did all sort of things - repair permissions, delete battle.net folder, etc. None of them worked. Got the error as well "Fail to write to a required file..". One thing that worked for me is following the instructions above. Step 2 wasn't clear whether it was / or i. It was in italics format that's why it looked like a / instead of i. After following the steps above, just cancel when prompted for admin password. Works for me now.
Reply Quote
Well after the fist failed attempt and a restart, I tried pressing cancel and got in. Great! Then I quit and tried it again. It asked for the admin password again. -_- really? Ok. So I pressed cancel again, and this time it sat there blank same as when I gave it the password the first time.

Honest, Blizzard, Blues, I'm ready to quit Diablo if you don't raise the quality here. I'm tired of all the hiccups with the patch/launch process and the auction house. There are errors in how the stats display in the game, I'v seen the same patch pop up at 100% every time I launch for a month now.

Do I need to hit cancel to an admin password request so I can hit a play button every time I want to start now? Get it together cus this is !@#$.
Reply Quote
Seriously, why does stuff like this happen every time there is a patch? Every time there is an update we have to do something different to get it working. Ridiculous.
Edited by ARK#1420 on 7/31/2012 3:46 PM PDT
Reply Quote
The reason it doesn't always prompt for a username / password is because"agent" is still running. Run activity monitor, stop the "Agent" Process and then re-open D3. It will re-prompt for username / pw again.
Reply Quote
Thank you so much. It helped.
Reply Quote
It didn't work. I followed the permissions instructions. Now when I open from the applications folder and ignore the password prompt I get an error message "Failed to write to a required file. Please close all other applications, temporarily disable your anti-viral software and try again".

Now what?
Reply Quote
This Worked for Me:
Run Diablo 3
PUt Password and wait for prgram freeze
Now open a terminal and type: (#indicates first line of terminal)
#sudo su (Warning whit this you become root)
#ps -fea | grep Agent (You see something like this)
01 306 1 0 0:02.87 ?? 0:04.57 /Users/Shared/Battle.net/Agent/Agent.1199/Agent.app/Contents/MacOS/Agent --locale=enGB
#kill -9 306 (You have to take your second column valor)
NOw yo have to put you password again, but the game run well now.
If you wish to re-run the game the cancel button now works.
Sorry for my english
Reply Quote
this works. thanks!
Reply Quote
MVP - Technical Support
90 Draenei Mage
6490
08/02/2012 03:10 AMPosted by Rogerdefl
Now open a terminal and type: (#indicates first line of terminal)


For those afraid of the terminal you can actually do what this post suggest with the Activity Monitor. You find this in the Utilities folder inside the Applications folder right where you find the Terminal app (for those wanting to do the terminal method)

#sudo su (Warning whit this you become root)
#ps -fea | grep Agent (You see something like this)


I haven't seen any other programs on OS X that name their process exactly "Agent"

So you should be able to use :

sudo killall -9 Agent

That way you don't have to remember to "exit" a root elevated shell session (which could possibly be dangerous)
Reply Quote
DON'T DO A KILLALL -9 Agent, list of proceses related Agent in my MacBook:

sh-3.2# ps -fea | grep Agent
0 34 1 0 0:00.06 ?? 0:00.09 /usr/sbin/KernelEventAgent
501 124 107 0 0:00.41 ?? 0:00.54 /usr/libexec/UserEventAgent -l Aqua
501 131 107 0 0:00.07 ?? 0:00.12 /System/Library/CoreServices/AirPort Base Station Agent.app/Contents/MacOS/AirPort Base Station Agent -launchd -allowquit
501 134 107 0 0:00.16 ?? 0:00.68 /Library/Little Snitch/Little Snitch UIAgent.app/Contents/MacOS/Little Snitch UIAgent
501 323 1 0 0:06.71 ?? 0:10.30 /Users/Shared/Battle.net/Agent/Agent.1199/Agent.app/Contents/MacOS/Agent --locale=enGB
92 338 28 0 0:00.05 ?? 0:00.21 /System/Library/CoreServices/SecurityAgent.app/Contents/MacOS/SecurityAgent
0 372 362 0 0:00.00 ttys000 0:00.00 grep Agent
Reply Quote
Support Forum Agent
Did we try this as well?

http://us.battle.net/d3/en/forum/topic/6232743280
Reply Quote
^^^^

this worked for me. now it starts up just fine doesnt ask for password and viola =] thanks
Reply Quote
Not figured out the root cause, but there definitely seem to be permissions problems with the files in the Diablo III folder. Something I find suspicious is that all those files are owned by the root user, yet they also have read, write and execute permissions anyway. Something for the devs to figure out.

I 'fixed' this by changing the owner of those files (and folders) to be my own user. Now that the files are owned by me, any program I start (including Diablo itself) can do what it likes with those files; there's no longer a need to prompt for an admin's password.

Warning: the workaround I outline here may cause other problems if several people use your machine and play Diablo. I'm the only user of my mac so I know this is appropriate for me. I'm making a couple of other assumptions that you'll have to adjust for your systems:

1) The folder containing the Diablo 3 installation is '/Applications/Diablo III'
2) the group owner of those files is 'staff' just as it is on my mac.

To correct, open a terminal and execute the following (substitute 'myuser' for your actual username)

cd '/Applications/Diablo III'
sudo chown -R myuser:staff .

The sudo command will prompt you for your password. Enter it.

The quotes enclosing the application folder on the first line are significant, you need to type them; so is the period at the end of the second line.

You should now be able to run Diablo without any annoying prompts for an admin password.

BTW, I don't take any responsibility if you manage to screw up your mac. Don't run these commands if you're not confident with the Terminal, or if you're suspicious of me :-)
Edited by gruffy#2147 on 8/2/2012 3:33 PM PDT
Reply Quote
MVP - Technical Support
90 Draenei Mage
6490
08/02/2012 10:00 AMPosted by Rogerdefl
DON'T DO A KILLALL -9 Agent, list of proceses related Agent in my MacBook:


Did you check the man page for killall ?

As I understand it only kills processes whose name exactly matches the pattern you give it.

So if you gave it

killall -9 Agent

Then it will only kill a process called exactly "Agent"

None of the processes you've listed are named exactly Agent and nothing else. They all have something different in their process name other then solely "Agent"

From the man page :

"The killall utility kills processes selected by name, as opposed to the selection by pid as done by kill(1)."

I've just double checked my figures. I had the same processes you were worried about. All were still running after running the killall command I posted as their process names did not exactly match the pattern i gave it.
Edited by Bluespacecow#1139 on 8/3/2012 10:23 AM PDT
Reply Quote
90 Undead Warlock
13035
This was driving me insane for the past 3 hours, finally looked it up and even though this is for D3 it worked for my MoP beta launcher with the same problem, just hit cancel. Phew, I was getting really pissed doing all sorts of stuff to try to get it working.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]