Diablo® III

Starcraft 2 not optimizing

I cant post on the SC2 forums because I haven't actually played the game yet / made a character yet. Not sure whats wrong with it, but after I downloaded and patched the game it tells me I need to optimize it before I can play it.

When I click Optimize it just sits at 0%. It doesnt move at all, I waited 3 hours nothing happened. I closed it and reopened same issue. It just wont optimize.

I have a 2012 edition MacBook Pro, so there shouldn't be any issue with the game being played. On top of that I allowed the game to enter through my firewall, yet it still won't optimize. I tried useing the repair files and nothing happened.

I have looked everywhere on the internet / forums and I cant find a solution to my problem. Anyone know how I can fix this? Or what the issue is? or get a refund? Cause if its not going to work then I would like my money back. I really just wanna play the game. I cant post anywhere else so this is my only real help.
Reply Quote
Idk why but with all launchers for my Mac (both SC2 and D3) I must cancel when it prompts me to enter my password. Not sure if this is what youre looking for
Reply Quote
08/08/2012 06:56 PMPosted by Dominator
Idk why but with all launchers for my Mac (both SC2 and D3) I must cancel when it prompts me to enter my password. Not sure if this is what youre looking for


I had that issue with D3 too. It doesn't ask for any admin passwords on SCII. I opened a ticket and looks like Im just going to have to reinstall due to corrupted / incomplete optimization files.

Thanks anyways :)
Reply Quote
80 Troll Shaman
2010
I have a problem also. My SC2 is at 1.4.3 and trying to patch to 1.4.4. Instead of patching it begins optimization. It starts and then stays at 0%. I have tried EVERYTHING. Been 3 days now and I still can't play any SC2.
Reply Quote
i had a similar issue where it wouldn't optimize, turned out that all (read: most) of my files in the SC2 directory were read-only.

i did a search for all files in that directory, highlighted all of them, and un-checked read-only from all of them real quick. i was able to optimize just fine after that.
Reply Quote
89 Orc Warrior
5105
yep me to just bought the game and cant optimize gg blizzard
Reply Quote
Same problem :( I just bought the game and can't optimize :( This makes me a sad panda :(
Reply Quote
90 Troll Shaman
5715
I have the probelm too, i cant optomize, but mine gets to about 8% and then gives me a message of "An internal error has occurred, please restart. If problem persist contact customer support." Which i havent even been able to get any info from them about this.
Reply Quote
I saw a list of troubleshooting steps somewhere on the forums for this issue and it fixed it for me. do a search. Try wording it a few different ways till you find what your looking for.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]