Diablo® III

Gtx 660m

Win,

This article/video on Nvidia's site should help with that.

http://nvidia.custhelp.com/app/answers/detail/a_id/2523/kw/optimus/session/L3RpbWUvMTM0NTUwMzkzMi9zaWQvbkYxTTNjNGw%3D

I'm sorry, I understood nothing from that video, I can barely hear it with max volume.

edit: now I know how to check if the gpu is being used and I will do that now...

edit2: yes the gpu is being used with Diablo 3 up.

edit3: uploading a video for you...

edit: and its not working...

---

I dont understand the issue .............
Edited by Win#1398 on 8/20/2012 6:09 PM PDT
Reply Quote
Im going to assume there is no hope...
Reply Quote
Support Forum Agent
Posts: 35,713
Win ,

You would have been using a third party app to measure the fps in-game as ours wasn't working until 1.0.4 came out today, so could you uninstall the other utility, (I'm guessing Fraps), and try the game again using the Control-R feature to display the FPS and report back what the results are? Make sure the in-game FPS limiters are disabled as I'd asked you to do earlier.
Reply Quote
Win ,

You would have been using a third party app to measure the fps in-game as ours wasn't working until 1.0.4 came out today, so could you uninstall the other utility, (I'm guessing Fraps), and try the game again using the Control-R feature to display the FPS and report back what the results are? Make sure the in-game FPS limiters are disabled as I'd asked you to do earlier.


FPS changes when using the ingame one, doesn't change the horrible experience and lag... How is that even a fix when regardless of what FPS I get, it is choppy and spikey?
Reply Quote
Support Forum Agent
Posts: 35,713
Win ,

I didn't mean to suggest it as a fix but it was possible the method you were using before was in fact interfering and possibly causing the very problem it was there to detect.

All I'm addressing here is your not getting a stable 60 FPS with Vsync enabled. Is it still locking at 50? Choppiness and Spikieness are another matter altogether.
Reply Quote
Win ,

I didn't mean to suggest it as a fix but it was possible the method you were using before was in fact interfering and possibly causing the very problem it was there to detect.

All I'm addressing here is your not getting a stable 60 FPS with Vsync enabled. Is it still locking at 50? Choppiness and Spikieness are another matter altogether.


Well now it rapidly changes from 60-1xx but yes its choppy and stuttery as I said previously.
Reply Quote
Support Forum Agent
Posts: 35,713
Win,

Have you tried the suggestions others have posted in the thread regarding the Nvidia Control Panel options? If it's going between 60-1xx you don't have Vsync enabled in the game, which is one of the suggestions above, but not mine.
Reply Quote
I have the same issue here. I notice the stuttering comes when I'm running around, and uncovering new areas of the map. It seems as though the loading of the map is causing all of this. If I run back and forth across the same area, the stuttering goes away once I load that area.

My FPS will stay at 60 even during times when I'm stuttering. Putting graphics settings to the lowest possible doesn't fix the issue.
Reply Quote
Tried everything, even put d3 on my SSD, no avail, also tried the sticky in this section.. nope...

still stuttering like a boss.
Reply Quote
90 Orc Hunter
940
Posts: 11
i just bought a g75 and i have the same lag while playing d3
Reply Quote
You need to go on Power Managment , when i make the Dynamic modes what are the best on lenov y580 than cap on 50fps , when i make on high work than running 60fps i think its a bug.
Reply Quote
50 Pandaren Monk
0
Posts: 7
I'd like to add I think I figured out what the issue is.

Diablo 3 is not being run on the 660m. I used the NVidia GPU Activity monitor to check to see if Diablo 3 was being properly allocated, and it is not.

Compared to WoW, which properly uses the GTX 660m as the GPU.

Diablo 3 does not. So it seems to be a Blizzard problem.

Note: I even used the right-click context menu to try and force the GPU to be activated. It just ignores the request.
Reply Quote
Same problem here, I have to play in fullscreen not even windowed fullscreen otherwise its literally unplayable ...

I have a msi laptop with 8GB memory, i53210M(2,5GHz) and a nvidia gtx660m.

I spent hours and hours to check if people had same problem, found nothin so far.
Reply Quote
50 Pandaren Monk
0
Posts: 7
I found a YouTube video of someone playing D3 with the GTX 660m on FHD, no lag whatsoever. But it was from 3 mos. ago, so perhaps one of the new patches for D3 disrupted the play-ability with the GTX 660m.

All I know is everything I tried fails to get D3 running properly on my lappy. And I can run Shogun II on ultra (minus aa) - so D3 should be a peace of cake.
Edited by Lukianos#1843 on 11/18/2012 12:32 PM PST
Reply Quote
Omarkos, are you still available?
Reply Quote
I hope this gets resolved, Win. I'm following this thread because I have the same stuttering issue with my GTX 560m.
Reply Quote
I'd like to add I think I figured out what the issue is.

Diablo 3 is not being run on the 660m. I used the NVidia GPU Activity monitor to check to see if Diablo 3 was being properly allocated, and it is not.

Compared to WoW, which properly uses the GTX 660m as the GPU.

Diablo 3 does not. So it seems to be a Blizzard problem.

Note: I even used the right-click context menu to try and force the GPU to be activated. It just ignores the request.


Ponjo,

Is the ability of the system to use the GPU or CPU to run graphics what NVIDIA calles "Optimus"? If so, are you saying that the graphics are being run on the CPU instead of the GPU and that is the issue?
Reply Quote
50 Pandaren Monk
0
Posts: 7
Drayven,

That is precisely what I believe the issue to be. The Optimus monitoring program easily lets you identify which programs are running off the GPU, as opposed to the integrated graphics.

No other game I play has this allocation issue, hence why I argue that the problem is on Blizzards end as opposed to Nvidia's (though I could be wrong).
Reply Quote
b
Reply Quote
I have exactly the same issue i have a core i7 3740QM 2.7 Ghz 8 gig of ram and a GTX 660m and when i run D3 in full settings with "smooth shadows" even my game is choppy and its just useless to play so i urge you blizzard please sort this out don't loose what customers you have left.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]