Diablo® III

Latency issues been "fixed"

They talk about "investigating issues" and "coming up with solutions" but all that is just company speak for "We will pretend to work on things, but no chance in hell we will actually address the problem by giving you local server support".


08/21/2012 06:16 PMPosted by Arcagnion
So has any else had this game play experience after the new patch 1.0.4?


Can you see a pattern here?
Blizzard doesn't even pretend any more.
This post speaks for itself.
Edited by Bohemund#1924 on 8/21/2012 11:26 PM PDT
Reply Quote
The 1.0.4 is likely to have latency issues as it seems to be attracting many that had previously left the game (myself).

The Latency issues seem to appear when servers are under load, such as opening weeks. The latency magically evaporate ... which was proportional to the player base also evaporating.

CS repeatively told me that the latency issues were at my end. Thanks for flobbing me off. Without changing anything it was resolved a few weeks later.

My point? Give it a few days for the load to even out.
Reply Quote
08/22/2012 12:03 AMPosted by IceMojo
My point? Give it a few days for the load to even out.


No. It's was still an issue for me - and others I knew who have since quit - way after launch.

I don't think this issue will magically disappear.

Veteran vanilla WoWtards like myself may remember Blackrock server. It was flagged as AU but the reality was that it was not hosted here and we still experienced terrible lag, but at least Blizzard could feel good about labelling one of their servers 'AU'.

At this stage I'm unlikely to purchase another Blizzard game.

I had exactly the same CS experience as you. Flobbed off, 'resolved' an issue which was anything but.
Reply Quote
I never... had any connection issues before 1.0.4 and i dont have any after it either >.> and i laugh at u guys lagging.
*laugh* muahahaha
Reply Quote
85 Draenei Death Knight
11035
The 1.0.4 is likely to have latency issues as it seems to be attracting many that had previously left the game (myself).

The Latency issues seem to appear when servers are under load, such as opening weeks. The latency magically evaporate ... which was proportional to the player base also evaporating.

CS repeatively told me that the latency issues were at my end. Thanks for flobbing me off. Without changing anything it was resolved a few weeks later.

My point? Give it a few days for the load to even out.


Problem is it doesn't fix the issue that we are treated as second class citizens. Game is playable, but that doesn't make it enjoyable, haven't played in yonks unfortunately, which is a shame, the game is good enough to warrant playing it here and there.
Reply Quote
I am still getting really extreme latency. It gets to over 1000msec consistently. It was better before patch 1.0.4 (i guess because hardly anyone was playing). I'm in Sydney by the way.
Reply Quote
Maybe the 3007's will also return!
Reply Quote
I think we all know that we shouldn't expect the new patch will fix the lag. If only because the software issue they should have done it for a long time, who would like to read all those annoying post about lag (I expect they read the detail of those message, not just the big topic). Obvious the lag is not the software problem.

if tweaking the game client can fix latency, then I don't think I need to upgrade my graphic card to get rid of graphic lag anymore
Reply Quote
I was playing fine until about 8pm eastern australia time, sat around 200-300ms.

then after that my latency increased to 600-1200ms betweten 8-10pm.

then just 10 minutes ago i was playing at 2600ms. =[
It's just as bad as it was at launch, if not worse.

Blizzard really needs to suck it up and provide us with a local server
Reply Quote
lag in public sucks bad bad bad.
Reply Quote
Patch 1.0.4 is awesome. Although i personally think the nerfs on Elite weren't really necessary.

One down side thought. I am getting massive rubberbanding.

250ms - 1000ms in intervals about 10 -20 seconds... then sometimes 500ms.

Really excited about the game but its unplayable.

Have no problem streaming videos in youtube, skype or web surfing.

Get this fix please. Or people will be running off to guildwars2.
Reply Quote
Blizzard just did a hotfix to improve rubber banding, be interested to see how people go tomorrow, lets see if it makes any difference for those of you still having issues.
Reply Quote
Pre 1.04 for me was fine, had no issues and game was running smooth.
Post 1.04 OH DEAR GOD!!! A couple more reasons to play my lvl 60's but dang the latency is huge. Poor Blizzard cant seem to get it right can they.


So has any else had this game play experience after the new patch 1.0.4?


nah since release........-.-
Reply Quote
Thanks for the update Narull, any hotfix note link you can provide us? Just really curious as how soon it'll be fix. Thanks again.
Reply Quote
The y posted about the hotfix here: http://us.battle.net/d3/en/blog/6871751

I assume it has been applied within the last couple of hours as it doesn't say a time just says it was done today.

Keep the info coming, hopefully it makes a difference.
Reply Quote
Pre 1.04 for me was fine, had no issues and game was running smooth.
Post 1.04 OH DEAR GOD!!! A couple more reasons to play my lvl 60's but dang the latency is huge. Poor Blizzard cant seem to get it right can they.


So has any else had this game play experience after the new patch 1.0.4?


I was rubberbanding/glitching quite bad yesterday ended up in being disconnected... see how i go again tonight i guess.
Reply Quote
Played last night and had no lag. Today has been atrocious. Since 8am (CST Australia) the best the lag has been is around 230. It has been sitting around 600 quite often, and frequently jumps to over 1200.

Loved last night levelling up paragon levels. Wanted to continue today, but it really is unplayable like this.

Hope there is a fix soon for this. Have always had some lag, but since 1.04 the lag truly is horrid.
Reply Quote
Considering we still don't have a local server, latency issues will never be "fixed". The thing about big corporations is that money means more than the customer, though on the PR front they pretend that it's the opposite hence why we have useless posts such as this.
Reply Quote
Offline mode +1.
Reply Quote
I have been experiencing the same rubberbanding problems. Especially with whirlwind.
It's not as bad as it has been, but it still exists.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]