Diablo® III

Latency issues been "fixed"

During Mon-Fri nights in Sydney, the game is great. Don't even realise I'm online. However, I find the lag on weekends can be inconsistant from being 'okay' to 'unplayable'. It seems when the Americans are on, it clogs the servers.
Reply Quote
During Mon-Fri nights in Sydney, the game is great. Don't even realise I'm online. However, I find the lag on weekends can be inconsistant from being 'okay' to 'unplayable'. It seems when the Americans are on, it clogs the servers.

Edit: Seems I'm lagging on the forums. I double posted. :P
Edited by Maiyart#1347 on 8/26/2012 10:54 PM PDT
Reply Quote
Posts: 1,137
View profile
Since 1.04 the rubber banding has been shocking. I dont know if others are experiencing the same problems I do. But prior to 1.04 I used to rubber band on occasion on my monk when I used tempest rush.

Now.. its pretty much 60%+ of the time I rubber band when I use it, so I actually quit using him.

Now I am finding on my witch doctor whenever I click to move AND cast just a fraction after it I will rubber band.

Also spell effects are killing me with no visual animations on a 230 ping (dying heaps to the poison spitting things that are on the walls in caves) and weird things like when a champ / elite dies and it explodes the explosion itself will cause me to rubber band.

Not sure whats going on but I hope its fixed soon, tho Panda is just around the corner;)
Reply Quote
08/26/2012 10:52 PMPosted by Maiyart
During Mon-Fri nights in Sydney, the game is great. Don't even realise I'm online. However, I find the lag on weekends can be inconsistant from being 'okay' to 'unplayable'. It seems when the Americans are on, it clogs the servers.


I get the same, weekend latency is high, but playable, weekdays are perfect.
Reply Quote
It's ridiculous here tonight in Auckland....1000+ latency so I logged out, now I can't even get the AH to open /facepalm

Back on, now latency is at 2000+ ffs
Edited by Gnarledoak#1610 on 8/27/2012 3:11 AM PDT
Reply Quote
I have 700+ms in public games. As a demon hunter this makes it impossible to play. I'm officially done with D3 until these issues have been fixed. Sorry, but I can't put up with it anymore. It's too damn frustrating.
Reply Quote
Looks like I spoke too soon in my previous comment.

I'm now getting upwards of 1225+ ms. It's totally unplayable.
Reply Quote
unplayable tonight as well. been bad since 1.04.
Reply Quote
I started to rubber band again past few days =/
Reply Quote
lag pretty much kills any build that requires minimal latency so the fact that we don't have our own servers with a decent ping actually impacts us playing the game. Can't understand why we actually accept a broken game. Try playing a WW barb with our pings and see what i mean. Hardcore mode is pretty much un-playable as you will die to the lag monster. Guess Bliz are happy to accept our $ but not front up with a few $ for decent server hardware for a pretty big region. Back to BF3 at least i can play on a server without much lag.
Reply Quote
85 Human Mage
3030
Posts: 11
I am in Canberra with Bigpond and the game plays smooth for me whenever I play, night or day. However, the first fight or two after logging on will ALWAYS be laggy. Then it is smooth for hours except occasionaly their is a split second pause here or there. BTW I am getting about 200ms latency.

Being with a cheap ISP that gets conjested is probably the main reason people get lag. Obviously there could be other problems like a computer hardware/software problem or a line problem but I doubt the problem is at blizz's end.
Reply Quote

Being with a cheap ISP that gets conjested is probably the main reason people get lag. Obviously there could be other problems like a computer hardware/software problem or a line problem but I doubt the problem is at blizz's end.


I am not sure what you think we are referring to as lag, but we mean where the game pauses for 2-10 seconds.. nothing happens then it suddenly catches up.. I have never seen any other server based game do that the way D3 does.. This issue is seen across all ISPs at peek and off peek times.. Then add in the rubber banding where you can get stuck in a loop for 5-10 seconds..
Reply Quote
85 Human Mage
3030
Posts: 11
08/27/2012 07:11 PMPosted by sjwt
I am not sure what you think we are referring to as lag, but we mean where the game pauses for 2-10 seconds.. nothing happens then it suddenly catches up.. I have never seen any other server based game do that the way D3 does.. This issue is seen across all ISPs at peek and off peek times.. Then add in the rubber banding where you can get stuck in a loop for 5-10 seconds..


I see. I never get the 2-10 second pause/catch-up problem. I do get very occasional rubber banding.
Reply Quote
Lag after patch 1.0.4 is many times worse than before the patch. Huge lag spikes and rubbering banding.
Reply Quote
Lag is worse than it's ever been.

Patch 1.04 got me back playing again, but geez, the lag is soooooooooo frustrating.
Reply Quote
This game could have performed so much better had David Brevik designed this game.

(David Brevik was the developer of Diablo 1 and 2).

Sorry current Blizzard employees but your Diablo 3 is simply lousy.
Reply Quote
Posts: 185
I was having no issue for the last few weeks and haven't experienced rubber banding since they fixed that, however ever since the patch 1.04 blogs have been posted i've started getting terrible lag all over again exactly like at launch. My guess is that alot of people have returned to the game since the blogs and the servers are dying again.

In short no it hasn't been fixed it seems, appears unfixable.


^ +1
It is fixable, prioritise non US traffic, oh wait, then US players will get 150 latency and cry, even though they are still getting a better service for less $
Reply Quote
I am in Canberra with Bigpond and the game plays smooth for me whenever I play, night or day. However, the first fight or two after logging on will ALWAYS be laggy. Then it is smooth for hours except occasionaly their is a split second pause here or there. BTW I am getting about 200ms latency.Being with a cheap ISP that gets conjested is probably the main reason people get lag. Obviously there could be other problems like a computer hardware/software problem or a line problem but I doubt the problem is at blizz's end.


How much did Telstra pay you for the ad?
BTW you being in Canberra and getting about 200ms is not really that good, I am in Hobart on a cheap ISP and don't have issues (except was down for a few days because Telstra wiring at the exchange was stuffed up giving me only ~2% the normal ADSL2+ performance), my latency is 200-220ms normally which is just as good as yours taking into account the extra mileage from here. The congestion problems are normally at the blizz comms server end. And sorry to tell you that the lags experienced the first period after v1.04 (up to and including last usa weekend) were clearly due to software/server issues on blizzard's end - avoided playing hc until yesterday for that reason because it was quite predictable.
Reply Quote
A lot of Lag Spikes since 1.0.4, in fact, D3 froze on me the other night... first time since launch. It starts out with frame drops, gets really choppy then chokes to death.

Load into a new area and you have to wait for 5-10 seconds for the frame rate to calm down before you can do anything.
Reply Quote
This is getting really frustrated.

I came back to play Diablo III after 1.04 patch and what I get is this latency issue.

I died 5 times and disconnected more than 5 times..

- -;;
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]