Diablo® III

Latency issues been "fixed"

Can anyone tell me how to check the latency rate?
Reply Quote
08/30/2012 06:52 AMPosted by markNana
Can anyone tell me how to check the latency rate?


The line left of the bubble on the right (usually green but as aus/nz special often yellow or red) indicates the latency - hold the mouse pointer over it and it will give you a number (ms latency).
Reply Quote
08/22/2012 01:23 PMPosted by Narull
Keep the info coming, hopefully it makes a difference.


It did not months ago.

It did not weeks ago.

It did not make any change right now.

Do not keep deluding others into wasting their time by posting 'info'. There's no reason to do so. You are either dishonest or misled if you keep telling others this will 'make a difference'.
Reply Quote
Pre 1.04 for me was fine, had no issues and game was running smooth.
Post 1.04 OH DEAR GOD!!! A couple more reasons to play my lvl 60's but dang the latency is huge. Poor Blizzard cant seem to get it right can they.


So has any else had this game play experience after the new patch 1.0.4?


At best my ping can get as low as 223, both pre and post 1.0.4x. But after 1.0.4x I have noticed more often lag spikes occurring, so yeah something needs to be looked at.
Reply Quote
08/31/2012 12:55 AMPosted by iBainesy
At best my ping can get as low as 223, both pre and post 1.0.4x. But after 1.0.4x I have noticed more often lag spikes occurring, so yeah something needs to be looked at.


As usual blizz released a new version (v1.04) without proper quality assurance which might have unearthed some of the developers mistakes - felt really good to find the "Developers Hell" last night and get stuck into them :)
So, as said, expect some problems every time there is any "upgrade" - at least for a week.
Edited by Asmodeus#6708 on 8/31/2012 4:57 AM PDT
Reply Quote
Pre 1.04 for me was fine, had no issues and game was running smooth.
Post 1.04 OH DEAR GOD!!! A couple more reasons to play my lvl 60's but dang the latency is huge. Poor Blizzard cant seem to get it right can they.


So has any else had this game play experience after the new patch 1.0.4?


I live in america and played there up until i came here to the sydney area to visit my girlfriend and since the patch i notice certain games are fine as low as 140 ping which is manageable and other games its constant 300-400+ worst rubberbanding of my life
Reply Quote
It getting worse daily again.

Time of day / night dosnt seem to matter.
Reply Quote
Lag Spikes and Rubber banding seems to be the Norm for us no matter what you try to do to mitigate the issue. Blizzard can do all sorts of stuff to make it seem better software wise but the reality is the only solution is for a locally hosted server which will never happen imo.

If they were truly serious about it, they would have done it on Launch of the game and not this far after release as the amount of people it will benefit is much less now. So forget about any Blue or Green posts about "We are looking into it and hope to make it better". It's just to string us along for long enough that we get sick and tired of it and finally quit. Problem solved for Blizzard, they have your money and are laughing all the way to the bank already.

Instead do what I am going to do which is never to buy another Blizzard game unless they resolve it once and for all with a local server. That's the only way they will realise it really matters to us, when it hurts there bottom line. Plain and simple. Let them explain to the Blizzard CEO why sales of Blizzard Titles are failing in Australia in the future. As they say, you have to spend money to make money. Spending money on a server would increase future sales and keep people playing rather than frustrated and quiting like many have already done.

I would rather spend my hard earned money on a game I can play locally and actually enjoy rather than be frustrated with lag spikes and premature deaths.
Edited by Wakt#6476 on 8/31/2012 9:27 AM PDT
Reply Quote
Why can't Blizzard offer say a Singapore gateway into their US servers? I am not sure if it is viable or not for this game, no idea of the technicalities of it but I noticed recently Path of Exile made a Singapore gateway available for their Oceanic/SEA users which took their ping from 200-300 to 90> on the US servers.

PoE is an indie on a shoe string budge so it is obviously not costly to provide this gateway as opposed to an actual server; is this viable or not?
Edited by Psychonaut#6330 on 9/1/2012 12:10 AM PDT
Reply Quote
Pre-1.0.4:
My latency was terrible with TPG. I switch to Internode and everything was awesome. My ping hovered around 220ms.

Post-1.0.4:
The game is now unplayable for me. My latency keeps fluctuating from green to red and back.
Reply Quote
Had my first experience with reaching a part of the Halls of Agony where I could literally go no further as the server could not provide me with a continuation of the hall I was walking down..

That, and the most amazing lag I've ever experienced really make me wonder...
Reply Quote
The lag for me has over the last couple of days got to a stage that playing is a waste of time, (Perth Australia) 280 avg ping :(

and i do enjoy the game
Edited by WATTERaso#6429 on 9/2/2012 5:29 AM PDT
Reply Quote
Question, does TPG use the telstra network to connect overseas? When I traced my hops, Telstra's international network to Hong Kong was the largest lag spike. From HK to the US wasn't as bad, weirdly enough.

Yeah, they should set up a server in Singapore. Singapore is small enough that all it's internet infrastructure is of high standard, and that'll allow us over here to get a better connection.
Reply Quote
Pre 1.04 for me was fine, had no issues and game was running smooth.
Post 1.04 OH DEAR GOD!!! A couple more reasons to play my lvl 60's but dang the latency is huge. Poor Blizzard cant seem to get it right can they.


So has any else had this game play experience after the new patch 1.0.4?


My experience has been brilliant since the new patch. I stopped playing well before it came out, and the new paragon system is something that has renewed my interest.
Reply Quote
So I was playing Diablo 3 about 4 hours ago and I was like "Hell I might go kill me some Diablo on inferno on my DH, so I got a tank friend and we went to where D3 is camping like a noob.
We get in and hes dropping quite fast, nek minit I see Diablo doing his special move which I like to call the " OMFG I DODGED THAT FIREBALL BUT IT HIT ME AND NOW IM DEAD WTH DIABLO YOU CHEATING SON OF A PICKLE " move.

Now you all know this move he takes a deep breath and snorts out a fireball on the ground that travels toward you and if and only if it hits you it will expand into a circle and you will hurt. Yeah that move.

So I was out of Discipline and I was like " ITS COMING STRAIGHT AT ME, I dodge it like a G six by a good 60cm (64.55 cm to be exact) but ofcourse NEK god damn MINNIT it registers that it hit me and I die. At this point in time I realize how much easier it is for Ameriapensis to do things like this.

And of course I take it out on Americans not Blizzard, but oh whoop-de-doo.

From this day fourth I vow, if I ever create a world class game, number 1 mmorpg game or just an epic game, it wont have USA servers! Yeah F&%K you America.

(Edit, I do love America and alot of Americans but sometimes harsh words are the best way to describe frustration )
Edited by NewZealand#1894 on 9/3/2012 4:38 AM PDT
Reply Quote
85 Troll Warlock
3630
Other than at launch, when it seems like nearly everyone was having latency problems, I've never had an issue. Enter 1.0.4, and I'll fluctuate randomly between 70 and 2000ms. The game is completely unplayable now, which sucks, because I loved everything about the new patch. I can shoot a stream of arcane orbs, or elemental arrows, or whatever else and my connection to the server is so inconsistent that no two are spaced the same distance apart.

Edit: I 3007'd while I was writing this post.
Edited by Schmetlappio#1433 on 9/3/2012 3:50 PM PDT
Reply Quote
Pre 1.04 for me was fine, had no issues and game was running smooth.
Post 1.04 OH DEAR GOD!!! A couple more reasons to play my lvl 60's but dang the latency is huge. Poor Blizzard cant seem to get it right can they.


So has any else had this game play experience after the new patch 1.0.4?


I have... :(
http://us.battle.net/d3/en/forum/topic/6490559547
Reply Quote
Latency for me (Canberra) has always been an issue. 1.04 it seems worse.

It's cool though as I will be moving to an area with no internet, so Diablo 3 will not be available.

Thank god for Torchlight 2!
Edited by Juzlee#1453 on 9/3/2012 9:14 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]