Diablo® III

Latency issues been "fixed"

09/03/2012 09:14 PMPosted by Juzlee
I will be moving to an area with no internet


Use sat phone - your latency will go up a bit :)
Reply Quote
In Perth and find the latency is normally in the green sometimes going to yellow and red. But what I have found is that it seems to be totally server related and nothing to do with ISP because at around 280ms is all you can hope for via ADSL because of physics.

What I have found to overcome the latency issue is to simply quit the game and enter a new game until you get a server that isn't over loaded.

Strangely it I can be in a game where the lag is in the red and everyone else is okay, then I exit and go into another game and I am fine but others are not.

I also find that some friends when they enter the game the game always lags, it is like I am having issue reading their player profile or what ever D3 does to get other player information.

At the start of a game sometimes I sit in town for 1-2 minutes as it appears when you first enter a game the client downloads map, player and monster information.

Another note this game has nothing to do with bandwidth it is all about latency the amount of data between you and the server is miniscule, so if you have 1Mbit or 100Mbit it really doesn't matter the only thing that really makes a difference is your ping.

Happy hunting and please Blizzard look into this back end server lag issue. (I personally think it is an issue between the game servers and the profile servers because a few weeks ago when there were issues with the profiles and Blizzard eventually reset all the servers leading up to that when ever a new player entered a game the latency would go into the red for minutes at a time).
Reply Quote
Just got the game. I'm thinking bad timing... Latency goes from green to red multiple times... Anyone heard of an expected fix? Just submitted a ticket but I'm guessing they can't help.
Reply Quote
Worse for me, crap to play.
Reply Quote
Having the same problem since friday the 14th. I live in brisbane and I randomly get bad laggs with 1k+ ms. I live in Brisbane..
Reply Quote
Hmm strange. I'm in NZ (Wellington Region) on an AYCE plan with Slingshot and don't have any latency issues. I've actually been playing quite a bit the past couple weeks and haven't noticed any lag or lag spikes.

Cheers!
Reply Quote
Pre 1.04 for me was fine, had no issues and game was running smooth.
Post 1.04 OH DEAR GOD!!! A couple more reasons to play my lvl 60's but dang the latency is huge. Poor Blizzard cant seem to get it right can they.


So has any else had this game play experience after the new patch 1.0.4?


Hmm come to think of it i do, never had a problem in previous patches was always 192-300
now it's constant. Tends to get worse when just one person joins my game. When i do a trace it's always in the 190s yet in game it's 380-1k.
Reply Quote
My lag has been bad post 1.04.

Shows green in the bar but my screen freezes and then my character finally can move after a second (or 3) later.

It is really frustrating due to the fact that a DH dies so quickly. Lag=fast death.

Also my account always logs itself off with -"input limit reached".

I am in brisbane with ADSL2+.

Good luck everybody!
Reply Quote
I would have added to this forum further but i just rubber banded back to googling pictures of Charlise Theron....
Reply Quote
I've just given up on playing for the night as frequent lag spikes (that pretty much kill me every time) ruin it completely.

Tonight I've been disconnected 5+ times. I have no problem at all with all the other games i play online.

That is unacceptable.
Reply Quote
Yeah this last lot of maintenance has pretty much killed the game for me. Has not been in the green all day.

Died more times today than the last 2 months totalled, money going down not up. Guess that’s what you’ve got to do to level.
Reply Quote
No still the same crap, lag, lag, lag lag lag lag ..........and more lag.
It starts at 5.30 pm our time each day that is when the yanks get out of bed and start playing the game, the servers cannot handle the load so we get the lag, Blizzard are too tight to put local servers here to fix the problem it eats into the rather large profits....another unhappy lag fed up player....this is my last Blizzard product no more you ! thanks for nothing you @#$@!#$#@!
Reply Quote
12/05/2012 01:00 PMPosted by PIEMAN
path of exile time people :)


yep i know this is what im doing :) got PoE last night. as soon as i saw the 10 hour maintenance notice this week which is primetime 5pm - onwards for perth, i just decided ive had enough. with all the lag spikes, im not even playing against the monsters/mechanics of the game anymore but im playing to combat lag + dc (playing hc)
Reply Quote
seriously blizzard @#$^ ...
Reply Quote
Had the lag since the game came out it stopped after a few weeks after the release and after patch 1.0.4 it came back and since then it is not going away. Blizzard needs to switch providers from AT&T and use something else.
Reply Quote
Latency is unbearable.........1800 ms-305 ms.....cannot do it anymore. It's OK, only 2 more months until Monster Hunter 3 Ultimate :)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]