Diablo® III

Can't play after 1.04 update

Updated to 1.04, relaunched, clicked "Play" and got the D3 logo, then a window stating "The application encountered an unexpected error" with the choice to reopen the app or close it and a code to use with Blizzard support. Tried again, same result. Restarted, tried again, same thing.

Then I checked the forums and saw a suggestion to delete my users/shared/battle.net folder. Did that, didn't help.

Does anyone have any idea how to fix this?

Edit: Mac is a 2011 MacBook Pro 13" 2.4 GHz i5, OS X 10.7.4
Edited by NonEpicTag#1252 on 8/21/2012 8:06 PM PDT
Reply Quote
I have the exact same problem, after updating with the new patch the game will no longer start. Is seems to crash/get stuck on the D3 logo.

I am running also on Mac, 2012 MacBook Pro Retina 15 inch, 2.3 GHz i7, OS X 10.8
Reply Quote
my problem is a little different, said i needed to download the latest patch before commencing play, did that and it says up to date...but when i attempt to log in it comes up that i still need to update before playing???

HELP!
Reply Quote
I have the exact same issue, though I have installed the patch it still tells me I need to instal it?
Reply Quote
Support Forum Agent
For those that are crashing, can you post the code your've been getting when it crashes?
Edited by Machkhan on 8/22/2012 11:07 AM PDT
Reply Quote
You mean these codes?

5D927E87-1862-404A-A0CD-4304CBE7AA08
CFEE608F-5784-4083-9A0F-D07990896BE8
Edited by Faelyn#1820 on 8/22/2012 2:31 PM PDT
Reply Quote
Support Forum Agent
Thanks. Checking these out.
Reply Quote
Support Forum Agent
Do you have any sound plug-ins installed?

/Library/Audio/Plug-Ins/
Reply Quote
I just now got this code:

695C2646-FFD7-4A23-B8D0-0FA0BFC8D8EB
Reply Quote
I'm having the same problem here.

Code: AF94584A-B49B-47D0-8BC9-6C22816C0BC2
Reply Quote
I am having somewhat of the same issue. I installed the patch then clicked play, it immediately launched an error window stating I need to do a system update.

Ran the system update and completed.

Tried launching Diablo, as soon as I click play this pops up:

"Diablo III cannot be opened because of a problem.

Check with the developer to make sure Diablo III works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and Mac OS X.

Click Report to see more detailed information and send a report to Apple."

Hope I can get an answer sometime soon to fix this issue.

This is in the report which has details about the failed launch:
"Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/Cg.framework/Cg
Referenced from: /Applications/Diablo III/Diablo III.app/Contents/MacOS/Diablo III
Reason: no suitable image found. Did find:
/Applications/Diablo III/Diablo III.app/Contents/MacOS/../Frameworks/Cg.framework/Cg: malformed mach-o image: load command #7 length (968896779) would exceed sizeofcmds (1848) in /Applications/Diablo III/Diablo III.app/Contents/MacOS/../Frameworks/Cg.framework/Cg
/Applications/Diablo III/Diablo III.app/Contents/MacOS/../Frameworks/Cg.framework/Cg: malformed mach-o image: load command #7 length (968896779) would exceed sizeofcmds (1848) in /Applications/Diablo III/Diablo III.app/Contents/MacOS/../Frameworks/Cg.framework/Cg"

Hope that helps in some way to resolve this
Edited by Mazed#1138 on 8/22/2012 7:34 PM PDT
Reply Quote
MVP - Technical Support
95 Draenei Mage
6555
08/22/2012 07:32 PMPosted by Mazed
Check with the developer to make sure Diablo III works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and Mac OS X.


Which version of OS X are you at ?
Reply Quote
I've been running into the same problem as the OP. Client's up to date with 1.0.4, but won't progress past the Diabloface when I try to play. I am currently running MAC OS X 10.6.8, and do NOT have any audio plug-ins installed.

Report ID as follows: 8A553C15-9033-4A8E-946F-EF00FC35DD9A
Reply Quote
I have a few things in that folder, namely Components, Digidesign and VST. I'm rather new to OS X though, so I haven't a clue what's actually installed or not.
Reply Quote
Posted by Mazed
Check with the developer to make sure Diablo III works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and Mac OS X.

Which version of OS X are you at ?


If you're asking me (OP), it's in my post: 10.7.4
Reply Quote
Any word on this? I just tried again, and it still won't work.

Error code: 47D51A72-98CA-4FB4-8659-3D989BC426C6
Reply Quote
Have you tried uninstalling and reinstalling?
Reply Quote
I also have this problem. It was working fine for a couple days and now it always freezes on the diablo logo. I'm forced to force quite very time.

Edit: Code is 2A718FFA-4A32-48B4-A568-784C4FDBBBE2
Edited by EEZ#1446 on 8/31/2012 5:32 PM PDT
Reply Quote
code is: 5CA1AF16-5C9E-49EA-8238-6E140F066A25
and B9FF7182-EBAF-42F9-AA29-78AD6E3A9D8C
and 54E96B9F-BE72-4593-A3DB-8CFC61F08B77
its giving me a different code everytime I try to open D3

I havn't been able to play D3 since monday aug.27

this is the d3debug.txt. if this help

2012.09.01 18:43:40.745170184 [12] err=2012 text=SFileOpenArchive - Open Failed - Data_D3\PC\MPQs\base\d3-update-base-10057.MPQ
[11] err=0 text=FileStack_Streaming::StreamingOpen - Unable to open the storage file
[10] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[9] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[8] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[7] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[6] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[5] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[4] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[3] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[2] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[1] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
[0] err=4 text=Posix Open (13) - Data_D3/PC/MPQs/base/d3-update-base-10057.MPQ
2012.09.01 18:43:40.745268553 ERROR: OpenMpq - Failed to open: Data_D3\PC\MPQs\base\d3-update-base-10057.MPQ, 2012
2012.09.01 18:43:40.745725476 ERROR: sOpenPatchMopaqs - Failed to open patch mpq!

Is it because I have Mac OS X lion 10.7.4
Is the problem being assessed?
update !! Still doesn't work sept 9th 15h00
Edited by Thornado#1775 on 9/9/2012 2:18 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]