Diablo® III

Installer stuck at 0%.

Originally I was having a patching issue where I would attempt to log on which made a patch alert pop up. This would then reboot Diablo 3 but then fail to patch because Diablo 3 was "already running". I figured I would just reinstall.

I am now trying to install from the game DVD but it hangs on 0%. I have tried running it in Administrator mode as well as a few of the basic solutions that are suggested. Nothing is working. How do I fix this.

Please and Thank you
Reply Quote
No info on this at all?
Reply Quote
I'm having the same problem
Reply Quote
85 Blood Elf Paladin
670
Posts: 3
I'm having the same problem too
Reply Quote
I'm having this same problem. I bought this game on release and it installed just fine. Just reformatted my computer and now it won't install. Everything is fresh and new, back to factory settings.

Using windows 7 with no virus protector on (uninstalled Norton).

Tried running in administrator mode, no luck.

Basically installer starts at 0% and does not move. I can hear my CD-ROM whirring so I know it is working. I can also go to "C:\Program Files (x86)\" and see the DiabloIII.temp folder. When I right click it, it gets bigger in file size as time goes by. Eventually it reaches 7.62 and stops there. If I wait about 5 minutes the installer then proceeds to 1% and pretty much stops there. If I close the installer I lose the folder and have to start over.

I haven't let it sit overnight or anything yet, and usually get impatient and want to try another solution, so that will be my next step.

I've already been playing this game since release, on this same computer for three months daily now. Not sure what to do.
Reply Quote
Posts: 1
No response to this??
Reply Quote
hello, try to run diablo launcher as administrator and compabilty windows xp sp3 (windows 7)
not workin eh?
windows 7 ----> show hidden files
search into c: program data ----> battle.net folder----> agent.db
open agent.db with windows program notepad but do not change anything
it will run installer move to 1%---- 5 minutes --->3% ---> 30-40 minutes---> all done
Edited by eneihem#1555 on 9/8/2012 10:51 PM PDT
Reply Quote
I had a problem after trying to install diablo 3 on my new pc, it wouldn't move a bit....(0.1% in 10 minutes), so after reading the posts here and trying everything you guys said and nothing working, a few hours later I installed direct x and other runtime libraries for another game, and now its been 7-8 minutes since I started the diablo setup again and its on 20 percent and going up normally so far.
Hope this works for you other guys

P.S. I also made an iso file out of the original diablo dvd earlier today, thinking if I mount it, it might go faster
Reply Quote
Hi, got the same problem now a few months later XD

But heres the solution:

In the installer go to 'HELP' and klick on 'Repair Tool'
Takes a few seconds and problem is solved :)
Reply Quote
5 Human Mage
0
Posts: 1
My repair tool is greyed out under the help window, i've been installing (reinstalling, after going through update hell for 3 hours) for half an hour and it's at zero.
Reply Quote
90 Blood Elf Paladin
0
Posts: 1
hello, try to run diablo launcher as administrator and compabilty windows xp sp3 (windows 7)
not workin eh?
windows 7 ----> show hidden files
search into c: program data ----> battle.net folder----> agent.db
open agent.db with windows program notepad but do not change anything
it will run installer move to 1%---- 5 minutes --->3% ---> 30-40 minutes---> all done


Tried this crazy theory, opened the file in notepad, gave it a minute, and installer came to life. It's going a bit slow but it is going, so this seems to have worked so far. Thanks for the tip.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]