Diablo® III

How to fix "can't patch 1.04" loop

I'm also stuck at 92% like the poster above me said. :(

I can literally see my download speed going from 30 kbps to 10, then 9,8, 7, 3, 2, 1 kbps....700 bytes, 300 bytes..20 bytes..1 byte..0.

Then the download speed dissapears completely..
Edited by BudgieMouse#1384 on 8/22/2012 7:57 AM PDT
Reply Quote
Posts: 8
Make sure u copied those "####" as well
Reply Quote
Ok when it stuck at 92% I tried deleting agent exe two times and also copied again into hosts file and it made it to the end finally.

Blizzard please name a legendary axe after this man. Thank you sir :)
Reply Quote
im so sorry but i dont understand the bottom part.

find a file named " hosts"change the authentication to all users to "full control"
Reply Quote
Dear Diablo,

What on earth is going on?. Did you sent your Lord of Lies to prompt me " exit the game and the patch will automaticall install " is a bull!@#$. It does not work!. i have change the language to all nation of the country and i have downloaded countless times but nothing happends!. What patch is this? i did'tn pay for this!. I saved all my money for this game and this is what i get?. Comon guys! what da hell.... dont you have a team of tester or something like that to do a test run before you release it?.

Yours sincerly,
the monk.
Reply Quote
Posts: 8
Just because if u do not change the file authentication, the system won't let u save your change of the file because it is a system file. By default only admin can modify the content of it.
Reply Quote
Im sorry i dont know how to change the file authentication pls advice
Reply Quote
Dear God,

Did what you told, did'tn work. I allowed all authentication on. even god and saturn can access my computer now, but it does not allow me to save still.

Cheers
The Monk.
Reply Quote
failed to download information about the next patch.check your network connection". Please help me with this. When i changed the patch_url to "http://enUS.patch.battle.net:1119/patch", this problem pop up to me. Please help me with this. Thx in advance.
Reply Quote
It worked for me !!!!
Thanks !
Reply Quote
how do i not change the file authentication pllzz help
Reply Quote
If you still can't get the patch - check here:
http://us.battle.net/support/en/article/diablo-iii-patch-troubleshooting-pc

There's a note about Safe Mode with Networking - I did this with the edited hosts file, and launcher opened and started updating. It did get stuck after a while so I returned to normal windows - ran the launcher again.

And it updated fine, and started downloading the patch!

Good Luck!
:D thanks Slayer for the host file edit!
Reply Quote
how do i do this?

change the authentication to all users to "full control"

ty.
Reply Quote
omg guys i have got a way to fix this go to this link http://us.battle.net/d3/en/forum/topic/5870687669 it worked for me
Reply Quote
Would just like to say a BIG THANK YOU.

Not sure what it did, but it worked.!!!!

Blizzard, LIFT YOUR FREAKING GAME!!!

Shouldn't take end users to sort out your patches.

Thanks again Slayer,

Appreciate it!!
Reply Quote
I shouldn't have to !@#$ing do anything.... the fact that I have had problems patching every single patch shows that blizzard is %^-*ing useless and need to get their !@#$ing %^-* fixed!!!

This is pathetic... I've heard that it's not much better on star craft 2
My friend can no longer play it due to patching problems...
Reply Quote
got problems with patching 2 , anyway this is how i have to patch every time ( using win xp sp3) ... :

1) run --> msconfig
2) uncheck load startup items
3) services tab --> hide all microsoft services --> disable all
4) restart pc and run d3
5) when you are done with patching return everything to way it was ...
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]