Diablo® III

[BUG] "Bashanishu" achievement not awarded

I just got the Bashanishu achievement. I still have the game open (for a few minutes more) if you want it.

I quit that game now. Hope it get's fixed for you guys.
Edited by Varangian#1719 on 10/26/2012 8:56 PM PDT
Reply Quote
Varangian is legit, let me borrow the sword and I got it.


Donated heavily to his cause(he didn't ask, but I was happy too) because trusting someone in this game deserves compensation.

Thank you.
Edited by MasterSet#1847 on 10/26/2012 8:03 PM PDT
Reply Quote
Hey guys,
I have a open game with Bashiok, but the wrong sword. If you want the achievement (I want it ;)) please bring the right sword for me ;)

edit: i became the achievement, but before i must test 8 (!!) different swords -.-
Edited by Skeletor#2616 on 10/29/2012 5:45 AM PDT
Reply Quote
Also bugged, I'm in a game now, hit in multiple times after farming for hours.
Reply Quote
I had the same problem a few days ago on my barb. Found bashiok in Inferno (MP0) but could not get the achievement (tried the blade many times with both a normal attack and Frenzy but nothing seemed to work)...wasted my 5NV stacks too! I found the blade quite some time ago (pre1.04 I think).
Reply Quote
Rakanishu's blade droped one hour ago, i hit bashiok and no achievement ... so bugged
Reply Quote
Same here.
Reply Quote
any1 having bashiok?
Reply Quote
Posts: 41
It does not work for me either i found two swords while looking for him normal in my DH i stripped down naked with no followers or pets! just malee i tried both blades I found with malee atack only i found both swords and monster on normal i hit him with the malee sword icon like 4-5 times naked nothing another 10 times i did more then hurt him he just layed there dead nothing.. also now the last talking to shen the jeweler quest "victory" since the patch isnt achievable either! i have killed the keywarden with 5 stack mp level 0-7 killed him about 30+ times each of the four wardens never got a single key i bought the plans from wert had 5 stack am i glitched too?
Reply Quote
dang u shouldve let me in your game ><
Reply Quote
Have a game open with bashiok, but dont have a dagger that works. anyone have a pre 1.04 rakanishu's blade? prob will be holding it open for another hour or so.
Reply Quote
still therE?
Reply Quote
Same thing just happened here.

Difficulty: Normal
Character: Level 34 Barbarian (Hardcore)
Region: US
No achievement.

Thoroughly disappointed.
Reply Quote
I am considering quit just because they can't fix such lame things. I found him only one time for over 500h of gameplay. I can't describe the feel... And it's like that from months! !@#$in' months, god dammit! Also that champion not-spawning thing is retarted as well. How hard it can be to fix issues like that. I am tired for waiting for patches just to fix some things that should be hot fixed ASAP. Couple of days ago I manage to go through inferno on hardcore and i have 94% of the HC achievements just cause they do not spawn the monster that I am meant to slain. I even didn't go for the possible ones, cause I don't feel motivation, only disappointment. Maybe that can screw me over just because probably some monster will not spawn in further patches. This game feels like beta for me even after almost half an year after the release date. Anyway, I bought some blades if somebody find that god damned moderator(or whtvr) in-game can add me, i will be greatful.
Reply Quote
I also have found bashiok today. I have the old blade rakanishu.

I hited him without skills and with skills and nothing happens.

Some dev can check this? Iam going to kill him to check if now we must kill it with the blade...
Reply Quote
I have a bashiok currently but i cant get the achievement

you can add me and join my game ill have it up for several more minutes
Reply Quote
Have bashiok, but not a working blade. Add me if you want to try with your blade or have a working one.

Edit: Game is now closed.
Edited by Naruil#1808 on 11/9/2012 7:34 PM PST
Reply Quote
he's in front of me right now. tried hitting him with and without skill. using two different blades. one of them socketed. both found on normal.i'm also on normal, playing a monk.been trying to find the little f***** for hours and it was all in vain. :\
Reply Quote
I have bashiok in game, but need a working sword, anybody can help ?
Reply Quote
Same problem here. I get the sword and found Bashion at the same map, done everything right, but no achevement pop up.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)