Diablo® III

Finally Stutter Free,I Feel Dumb...

TriggerSaint BTW...

THANK YOU - they PhysX change did improve my situation.

Great find - it should be added to the tech support script if any "mucky-mucks" are reading this thread.
Reply Quote
I tried changing the PhysX but still get the micro rubberband/stutter?

What are your ingame settings? I have vsync on due to tearing.

I'll try the beta drivers, see how that goes.

Just read the sticky... "Three performance-related issues in Diablo III seem to be centered around using the Vsync setting in the in-game video options, disk asset loading stutters, and a possible overheating issue."

I guess we just have to wait?


http://us.battle.net/d3/en/forum/topic/5596249920

We have waited for over three months.
Reply Quote
There is no need to change ANYTHING!!! Game worked perfectly before this hotfix patch that came out just after then 1.04 patch. Now after this hotfix patch game is rubberbanding so much its crazy. So its not us needing to change anything, its Blizz that needs to reset the game as it was before the hotfix patch.

For people that had the problem before the hotfix patch, yes, you will have to laborate with your computer because its not hotfix related, you had problem before the patch as well.
Reply Quote
Did anyoen find a solid fix for this? im using a amd gpu so i cant do the nvidia fix
Reply Quote
Just got back from being BANNED from the forums for a week. They said I was spamming when in reality I was trying to help others with the stutter issue. I don't feel like a fan anymore... or a valued customer...

Currently what is working for me: Old Nvidia Driver 296.10, in Nvidia settings set vsync to "force on" In game settings set vsync to off. I still get stutter in lots of areas but it seems they have improved some things because the stutter isn't as bad as it was... BTW hardware class is at 4 now...
Reply Quote
^^

296.10 upped my fps about 10, but vsync forced on did nothing for me.. still getting about 15-20fps :(
Reply Quote
Yeah the 296.10 drivers are what helped most for me. I have it forced on in Nvidia and on in game I just realized. Act 1 seems pretty smooth now but In no way can I advance to act 2 or 3 yet. Too much stuttering... Soryy man :(
Reply Quote
^^

296.10 upped my fps about 10, but vsync forced on did nothing for me.. still getting about 15-20fps :(


What is your monitor's refresh rate? And what graphics card are you using?
Reply Quote
Thank you for the third post.

Started stuttering every couple of seconds a few days ago. GTX 560. Switched Physx processor from auto-select to CPU. Bam no more stutter.

You're a legend. It was driving me nuts.
Reply Quote
09/06/2012 10:28 PMPosted by TriggerSaint
What is your monitor's refresh rate? And what graphics card are you using?


Here's my thread here, give me a bump and request sticky :)

http://us.battle.net/d3/en/forum/topic/6412415163?page=1

I updated to 304.79, played around with some of the video settings had its basically given me the same results as 296.10. With the rig I'm running I'm willing to put a bet that this issue has nothing to do with the video drivers/gpu.
Reply Quote
- Diablo III (Hardcore)
Posts: 1,618
View profile
08/29/2012 08:34 PMPosted by TriggerSaint
I think the reason for stutter on such high end cards is because D3 doesn't yet understand how to full utilize your G.Card.


Well, this is just a crazy idea from someone with little knowledge of hardware stuff, but....

If the problem is D3 not being able to handle your high-end card, have you thought about underclocking it, or otherwise dumbing it down? Maybe that would solve the problem for high-end card users until Blizz gets a proper fix out?
Reply Quote
No answer yet blizz?
Would really love to play the game I bought... on my top of the line computer jesus christ.
Reply Quote
i had the same problem a couple of months ago and after 1 maint night it "fixed itself" ....after 1.04 was fine playing good then a couple days ago they had small update or maint ? bang problems all back

frames go from 50 to 2 before i see a vortex elite ( can be off screen )
cant walk into the crater in act 3 frames drop from 50 to 7 , no mobs on the screen , game over

what ever u installed blizzard techs u broke it like it was broke b4 !!!!!!!!!!!!!
Reply Quote
09/07/2012 07:53 AMPosted by Galx
I think the reason for stutter on such high end cards is because D3 doesn't yet understand how to full utilize your G.Card.


Well, this is just a crazy idea from someone with little knowledge of hardware stuff, but....

If the problem is D3 not being able to handle your high-end card, have you thought about underclocking it, or otherwise dumbing it down? Maybe that would solve the problem for high-end card users until Blizz gets a proper fix out?


I have underclocked AND overclocked. Trust me...I have tried everything under the sun, so I and others can play.
Reply Quote
Getting worse by the day, I'll play with my friend and it literally freezes up every couple mobs. If there's anything effects on the screen it will freeze and lag. This is complete crap, I have an awesome computer that runs every other game flawlessy, then diablo on low settings can't even run properly?
Fix this crap now. we've been waiting long enough when we shouldn't even have to deal with this in the first place!
Reply Quote
Blizzard, you deserve an apology. I am sorry for blaming you for the stutter.

I feel dumb now, anyone reading this, please don't give me a hard time, I am posting this to help others with this issue... 550TI User
....


grats on voiding your warranty.
u shouldnt have to change anything to play a game.
and besides, the problem is with the read/write performance of the game to your hard disk. that's why the problem hasn't gone away. nice try tho.
blizzard needs to jus fix their game.

=================================
on another note, this resolved my stuttering problem tremendously:
http://us.battle.net/d3/en/forum/topic/5051865438#2
Edited by Gör#1270 on 9/10/2012 6:24 AM PDT
Reply Quote
In 1.03 they changed how the assets were loaded from the drive. Not sure why as it seems to cause more problems than it resolved but this will cause the pause and fast forward "stutter".

I'm on a stock 560Ti (850 core clock) and stock 1090T with 8GB RAM (1600) with a <=50MBps 500GB HD and the only problems I have had is when it loads assets and when either the server or Internet drops packets and causes rubber-banding (moved but was jumped back 40ft). I'm also only at 1280x1024 with high settings except for shadows (medium-smooth). If I max out then I can't play. I also get some slowness with water or MANY characters/items onscreen but it doesn't last very long.

If you're max'ing out your settings and resolution that is probably the problem.
Reply Quote
I am so unbelievably dissapointed with Blizzard after this game, it is just mindblowing that they released this game in this form.

I put up with almost every freaking BS you delivered with this unfinished mess, but this stuttering is just too much.

I can hardly play it on my own, due to stuttering I cannot control in any form, but when playing multiplayer it is just ridiculous.

My framerate drops to 2 frames per second. I fuc.king bought a new PC for this game, and the framerate drops to 2 fps. Unbelievable.

I tried every.fricking.solution posted in this forum and NOTHING even remotely works. So thanks Blizzard-South ... you ruined this franchise for me and many many other pissed off gamers, and frankly you deserve this pile of s.hit that is raining down in this forum on you.

Sorry, all of this anger piled up since the 19th of may and I always kept my mouth shut, but trying to play a game with your friends and end up hating it so much that you just want to throw the fuc.king harddrive out of your window is not really what I imagine under a satisfactory gameplay experience.

Fix your game ffs.
Reply Quote
sad truth but the only way to fix all this. is to get a ssd! or so i heard.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]