Diablo® III

FPS drops because of Physics?

Allright, over the past 3 months I have seen some fps improvements. The game is very well playable and i'm getting around 40/50ish fps. I am running a mid-2010, i5, 330m GT 256, SSD, 8gig RAM.

All seems well, until I start destroying stuff. Doesn't matter what size: a pot, a barrel or pillar. The first second my fps will drop by 20 and if there is lots of pots/barrels/pillars it will even drop till single digits.

Am I the only one having this problem? (I doubt it)
And does blizzard know this?
Reply Quote
I have the same issue. It never happened on my PC, only happens on my Mac. I'm running a MBP Retina.

Whenever a huge amount of objects are broken, the FR drops down to single digits for a second or two. It doesn't happen for spell effects, etc, only for objects. Not sure what causes it.
Reply Quote
Indeed, if this wasn't happening I would be able to play fluently.
Reply Quote
So i've done some research, lots and lots of people are reporting that there is something wrong with the physics engine. Although i've not seen a single blue post on this. I would love a confirmation from blue's if they know about this and if it's being adressed.
Reply Quote
I'm experiencing the same issue since D3 launch. I'm currently using Firebomb with Flash Fire rune on my WD and it's more annoying now than ever.

FPS drops from 35+ to under 5 playing fullscreen (1920x1080) with Physics set to "Low".

iMac 21.5-inch, Late 2009
3.06 GHz Intel Core 2 Duo
8 GB 1067 MHz DDR3
ATI Radeon HD 4670 256 MB
Mac OS X Lion 10.7.4
Reply Quote
I just hope that more people are aware of this problem and post in this thread to get attention of a blue
Reply Quote
I noticed the same behavior. It's infuriating as otherwise the game appears to run "fine" (well, on a mid '09 13" MBP), even when I destroy stuff. Then comes a point where it simply doesn't handle physics anymore. It may be CPU heat accumulating and temporarily being overloaded when the physics engine kicks in, or some memory leak.
Edited by lloeki#2303 on 9/1/2012 7:37 AM PDT
Reply Quote
The FPS drops when I destroy anything including mobs and bosses, from 60~80 to 8~20.
Reply Quote
I've done some more research. Some windows users were able to make it smoother by adjusting the core affinity. This however is not possible on a mac.
Blizzard choose to develop their own physics engine after using Havok. I have to give them credit: it looks awesome, when it works..
Reply Quote
It's been like this since beta. It was worse in beta. Made posts then, not fixed even now. fuuuuuu >.<
Reply Quote
I get huge FPS drops when barrels break and stuff is flying all over the screen. It's annoying because I get a smooth 60 FPS otherwise on my Retina MBP.

I bet there is something they can do about it. I remember like two patches ago, I used to get a framerate drop when the templar would break the wooden barrier before fighting Jondar. Now, there's no FPS drop when the barrier breaks. Hopefully they can fix the rest of the physics in the game.
Edited by zuffcat#1583 on 9/4/2012 1:12 PM PDT
Reply Quote
So I have had this same issue since the patch before 1.04. I'm running on an early 2011 13 inch MacBook Pro. I saw a post discussing their poor performance and how messing with the settings and turning things up improved their performance, so I gave it a try. I turned the physics on high from low with low fx still selected. This improved this issue significantly for me. I still get the frame rate drop every once in awhile, but not as much as before. Give this a try and see if it helps you guys.
Reply Quote
MVP - Technical Support
Posts: 10,996
View profile
It's been like this since beta. It was worse in beta. Made posts then, not fixed even now. fuuuuuu >.<

actually they have done a lot to fix it since beta. The scene before jondar for example, used to be so bad, it'd lag even highest end mac pro when objects were destroyed. the jars, used to be individual objects instead of multiple objects consolidated into a singular.

they havent done much to fix engine. but they have reduced detail on a lot of objet destructions to reduce the effect it had on gameplay.

As for core affinity, unfortunately that's an OS X issue. OS X doesn't let the user do that, which is a shame cause OS X doesn't always know what's best for application performance.
Reply Quote
Blizzard Employee
Posts: 14,784
Shouldn't be the case.

We do have an a bug in about stuttering, which can cause this behavior here: http://us.battle.net/d3/en/forum/topic/6369438018

It is possible for certain machines to experience "stuttering" when all of the game's assets are fully loaded. Our testing has concluded on this issue and Blizzard hopes to have this resolved in a future patch.


If you're experiencing just overall low performance/FPS, that is something different that is being researched here: http://us.battle.net/d3/en/forum/5386228/
Edited by Machkhan on 9/5/2012 4:21 PM PDT
Reply Quote
Yeah I have the same Problem.
MBP w/R
2.3 GHz i7
16 GB 1600 Mhz

I can turn EVERYTHING low.. (which shouldn't have to be an option for what i'm using)
and once 5 monsters appear and kill them. lagg spike for a good 1-1.5 seconds. which gets annoying when farming.

I see that they will fix it in the next patch.

I'm sure they will.
Edited by Technoz#1968 on 9/5/2012 5:48 PM PDT
Reply Quote
i having this same problem! I contacted blizz support and they have nothing but fail idea's on how to fix it.

i hope its fixed in the next patch anyone know what that is?
Reply Quote
90 Human Priest
6220
Posts: 13,823
The users here are right Machkhan. The FPS will tank the moment objects are destoyed, even on Low physics, and remain tanked until all objects come to a rest or are "dismissed" from the playing field. It's as if the game goes into "Matrix Mode" where everything is in slow motion, only the mobs (as far as the server is concerned) are not, and...well, it doesn't always end very nicely.

The two main culprits seem to be physics and anti-aliasing. Disabling those two options brings the most improvement to FPS on the Mac client overall, but especially when breaking objects (though this still doesn't eliminate the problem).

Also, you might want to let the web team know that the invalid HTML bug that occurs when there is more than one battle.net link in a quoted post (such as yours above if I try to quote you) results in the inability to post/submit a response.
Reply Quote
Blizzard Employee
Posts: 14,784
I'll have S4d1k check this out.

09/11/2012 04:13 PMPosted by Tiapriestess
Also, you might want to let the web team know that the invalid HTML bug that occurs when there is more than one battle.net link in a quoted post (such as yours above if I try to quote you) results in the inability to post/submit a response.


Will do.
Reply Quote
90 Human Priest
6220
Posts: 13,823
Cuttingedge,

Your post as-is does not belong here in the tech support area. Unless you are experiencing the problem noted in this thread, can provide specifics to your machine, and post without the inflammatory rhetoric that you just gave us, you are doing nothing but derailing the thread.

And just an FYI - no game is released bug free. In virtually anything released nowadays, there is almost a certainty that there will be at least one or two bugs present. They may be hard to find, or may jump out at the users right away. Oftentimes they are something that the developers (in this case, the Mac client team which includes S4d1k) might not necessarily be able to catch in the limited timeframe they have to get a patch vetted and out the door.

There was a CPU bug in WoW very recently that even with players showing Blizzard the exact thread causing it took them a fair bit of time to fix, and then verify the fix was legit and didn't cause other problems. You can't just snap your fingers and make a bug go away.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]