Diablo® III

Graphic lag after 1.0.4 patch / FPS DROPS

I'm making another thread about this problem, hopefully Blizzard will notice...

Problem: Game is impossible to play due to Graphic lag after patch 1.0.4

I've tried downloading latest drivers for my card, I've tried lowering settings to minimun, I've tried everything...notice that before 1.0.4 the game worked fine, even with maximum settings now is unplayable

AMD A4, 4GB RAM, WIN7 64 bits, AMD RADEON HD 6480G

I can't post my DXDIAG because I'm not writting this in my computer, i will do it later
Edited by Baphom3t#1740 on 8/29/2012 4:54 PM PDT
Reply Quote
I know right... gotta I7 3.7, 16 ram cross fired quad GPU HD 3890 and still lags like shiat, Seens they added auction with real money I bet its all hackers trying to get in and ..you know steal
Reply Quote
Same here, I already changed my hardware class to 1 and also did the stickied "recommended fix" above. Getting 12fps at intense situations at 1.04.

i5 2500k, gtx 680, 8gig ram
Reply Quote
Same. Computer is extremely powerful for this game and getting huge fps drops.
Reply Quote
Same here. Evey game is lagggggg and die. Boy what fun!

Ive done every type of tweak in the config file, I've de-indexed my drive. Anything and everything and nothing fixes this crap. It was already bad before the patch but now its unplayable.

Nvidia 550ti.
Reply Quote
BUMP, WE WANT AN OFFICIAL RESPONSE FOR THIS PROBLEM
Reply Quote
Im getting well above 80fps, but since 1.04 get a stutter running past objects
1080p 23" monitor
I7 3770, 550ti, 10gb ram

I get the same results on 720p with everything on low.
Reply Quote
totally unplayable here since a couple of days after patch 1.04.
Im running i7, 16gb ram, 2gb gtx560 more than enough to run a game like this,

I have plenty other "online" MMo's that run smooth as silk with huge graphic demands compared with Diablo.
I've put in CS Tickets, I'm hoping I don't get the usual "we are looking into the issue" or even worse, the "its your fault! check this, this, and oh yeah sit with one leg pointing east south east" reply.
Reply Quote
I've put tickets too, their answer? "uhmmm maybe u need to update ur drivers" NICE ONE.....

BUMP
Reply Quote
23 Night Elf Rogue
180
Posts: 2
Same lag issues for me - it was fine before the update so I don't think it is my hardware. I'm giving it a week or two and if it doesn't improve I will cancel my account - not worth it.
Reply Quote
Same here GTX 560... Can run bf3 with no lag on everything ultra and textures high (1280*1024 thats my max resolution on my monitor >.<) and im getting fps drops to like 12 at crowded areas and if its with party oh boy than people we have a trouble here! one is afk! cause of the lag. No fix - account cancel. :)
Reply Quote
same problems here. ive messed with a lot of things and got it to the point where its playable MOST of the time. heres what ive noticed.

- act3 is by far the laggiest act of all

- dont touch breakables. if you start blowing crap up it will get really slow.

- entering any new area whether your walking or using teleport will be laggy for

- new monsters entering my screen(especially elites w/ molten) = lag(not always with trash but sometimes)

- keep depths certain rooms = lag. not so bad after u sit in the room for a minute but it makes the runs take FOREVER

my problem is NOT completely fixed but i can play again with out dying every minute from it, but i still get the occasional death here and there.

EDIT: act1 is the most playable of the acts. little to no bugs//lag. there is certain areas on HoA that are pretty laggy (the side rooms with the couple of breakables are pretty crappy) Seems like entering doorways in certain dungeons are just too laggy IMO

PRE-1.04 i had no problems but then again i recently upgraded my gear so i could farm act3 with somewhat ease so at first i thought maybe my computer needed to load these areas a few times to get used to it but ive been running the WHOLE ACT for about 4 days now and no changes.

PS- the server restarts this morning seemed to help a little
Edited by LarryG#1857 on 8/31/2012 5:51 PM PDT
Reply Quote
Posts: 1,069
View profile
This game was unplayable at first for me; for some reason my FPS was extremely low even on the lowest settings. Then they fixed it with one of the patches, and without changing graphics cards, everything was great. I was getting 30 fps.

Now the FPS is back down to under 15 in the sewers type areas, and under 5. I can barely move in the sewers. Almost lost my monk just now because my FPS in the waterlogged passage were so low, none of my keystrokes for my abiilties worked. What is going on?
Reply Quote
23 Night Elf Rogue
180
Posts: 2
Ok, not sure why Deafy is the one character as spokesperson here but -- what the hey (Funny that he is my a character my 5-year-old nephew and I play together :)

I did update my drivers and it made a big difference. I found this article on how to do it to be very useful:
http://www.makeuseof.com/tag/safely-easily-update-video-card-drivers/
The graphics look great but I'm still getting lags and uneven movement (like I go into slow motion) and sometimes jerky movements. And the battlegrounds are weird. Some of the weirdness may be due to the new spells, etc. but I'm finding there still is a speed issue - its not consistent.
Reply Quote
Posts: 1
Sounds like my problems, Mainly going into unexplored areas. I struggled through it to kill the skeleton king. Its funny, the game ran better when I played it while it was still downloading. I also get really bad sound errors, echos and misaligned dialog.

I have a i7 2.2 8gigs ram, Geforce GT 540m 1gig. Runs bf3 on most of the ultra settings. Its not over heating, my GPU got hotter running Civ 5 maxxed out.

I thought it might be back ground Sony Vaio crap so I've tried playing it in just past safe mode with only the most necessary processes running. I've tried the normal and the Beta driver for the 540m.

And the lower resolutions and settings to lowest.

My gut was telling me it might have to do with all the sound errors I'm getting. Either the sound is the problem or the lag is causing the sounds to be weird, though the sound issues happen without lag.
Reply Quote
Same issues here. I bounce from 50 fps to 5 fps every time I engage new mobs. I have an i5 with 4 gig ram and a 1 gig vid card. This doesn't happen on other games like GW 2, BF etc. This started happening about 4 days ago. I played directly after 1.04 and it was fine, just recently it's started happening. I can't play anymore and it's extremely frustrating.
Reply Quote
Same as everyone else over here. Game worked great, then came the patch and it lags like hell. Doesn't matter if I'm on low or high settings.
Reply Quote
90 Draenei Warrior
14145
Posts: 3,147
I've been having some kind of situation myself, which I had just made a topic about to see if I can somehow resolve it.

Essentially, there are times where the game will freeze on me, typically during a high action sequence, and stay that way for either a good 15 - 20 seconds or so (or just freeze completely), turn to a black screen, then the screen comes back and I am back in the game... though usually dead. This has ONLY happened since the patch hit. Also, I do get MINUTE lag here and there when I move, but that usually resolves itself in a right hurry.

I updated my graphics card driver, shut down background programs... nothing. My GPU Temp, when the game is running, is at 58C, though this is me by myself and no combat happening. I do not know what it is during a high action sequence because I'll probably be too busy fighting for my life than trying to see what things are like. I also do not know if this will happen to me when I play alone, as I usually play Public Games to maximize chances of good loot for everyone.

I hope I can find a solution for this, otherwise I'll have to give D3 a vacation. And it ONLY happens with D3 and ONLY after this patch went live.
Reply Quote
been having some frame rate issues post patch 1.0.4. My character sometimes gets these horrible lag spikes that slow its movement in game. Before patch 1.0.4 everything worked smoothly, and i had no problems with the game. Now it is barely playable. Can we get a blue post in here? :p
Reply Quote
09/02/2012 09:47 PMPosted by Fatalkill
Can we get a blue post in here? :p


Nope mate sorry, blues don't even enter in any "fps issues" post because they don't know how to fix it, this is a problem that's been here since May 15th.

same problems here. ive messed with a lot of things and got it to the point where its playable MOST of the time. heres what ive noticed.

- act3 is by far the laggiest act of all

- dont touch breakables. if you start blowing crap up it will get really slow.

- entering any new area whether your walking or using teleport will be laggy for

- new monsters entering my screen(especially elites w/ molten) = lag(not always with trash but sometimes)

- keep depths certain rooms = lag. not so bad after u sit in the room for a minute but it makes the runs take FOREVER

my problem is NOT completely fixed but i can play again with out dying every minute from it, but i still get the occasional death here and there.

EDIT: act1 is the most playable of the acts. little to no bugs//lag. there is certain areas on HoA that are pretty laggy (the side rooms with the couple of breakables are pretty crappy) Seems like entering doorways in certain dungeons are just too laggy IMO

PRE-1.04 i had no problems but then again i recently upgraded my gear so i could farm act3 with somewhat ease so at first i thought maybe my computer needed to load these areas a few times to get used to it but ive been running the WHOLE ACT for about 4 days now and no changes.

PS- the server restarts this morning seemed to help a little


Same problems here, I noticed the same on breakable stuff those things drop my FPS to 0-3
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]