Diablo® III

Constant Lag Spikes

We should start a D3 victims support group.
Reply Quote
Having same issues. Playing fine for period of time (10-20 minutes) and then all of a sudden a lag and everything stops for good 10 seconds. If this happens in a boss fight I just "wake up" dead. And on HC that's pretty rough :)
Reply Quote
Having the same issue. Just sent in a ticket to Blizzard asking for a fix or to refund my money for the game. The game is unplayable in single player at the moment. Constant death because of the lag spikes.
Reply Quote
Same here. Started 3 or 4 days ago. But no any lag at the morning (6.00 - 9.00)
Reply Quote
Happening again as of tonight...FIX THIS CRAP.
Reply Quote
I have died about 20 times in the first few parts of my inferno run, each and everyone due to a lag spike just as im getting into the enemies....Very frustrating
Reply Quote
bump, lag spike is officially killing my dh more than phasebeasts. GG blizz.
Reply Quote
yes, this has been an issue for me too. from what I could tell, it seemed to lag more on Friday & Saturday... Sunday night, ping rates were actually reasonable (<200msec). Is this dependent on time of day / week, or has this been an issue at all times of day any day of the week?
Reply Quote
this is ridiculous fix this blizz
Reply Quote
same thing...just got a new laptop I dont have the problem on my desktop...but the laptop has unbelievable lag spikes every minute or so. both my desktop and laptop are on wireless. I've tried opening all ports suggested in the blizzard technical support.
Reply Quote
same issue.. tried almost everything (changing settings in bios, reinstall whole disks, changing every single setting in diablo and nvidia and etc) but nothing helps.. so it's something wrong with the game i think, cause in other games i have 0 probs.. just feels, that those physics (moving ground, lighting, effects, exploding boxes and etc) lags so much. so i hope blizz can fix this somehow
Reply Quote
Massive lag spikes for the last week here. It screws with my fury generation and breaks my build sometimes, very frustrating.
I guess we slowed down our RMAH usage so the 'subscription' the community paid for the Greyhound is gone, now the Hampster is back on the server wheel.
MoP players pay out the A thou so they prob gave all the cheetahs to them.
Reply Quote
Please fix this. Game is barely playable.
Reply Quote
Posts: 38
I'm having the same problem after patching to 1.05 and.... I CAN'T FIND A FIX ANYWHERE!!!!!!!!! NOT EVEN A BLUE SAYING SOMETHING ABOUT! THIS IS FRUSTRATING!!! HELP!!!!!!!!!!
Reply Quote
Posts: 2
I'm having the exact same problem
Reply Quote
Posts: 15
Having the same issue but worse. I lag every minute at least for 3-5 seconds. It's killer. Not my comp and not my internet. Both are super fast and I've run diagnostics on them.
Reply Quote
@nickelfire its REALLY overloaded atm... Iv been getting massive lag since i got home... Over Bnet website and In game... ALL other websites and streaming are still working fine... but D3 Server is GIBBED atm...
Reply Quote
Posts: 38
Come on Blues... are you guys blind? can't you guys see these threads? or are you just ignoring us??
Reply Quote
REPORT YOUR PROBLEM IN THIS POST SO WE CAN MAKE A BIG ONE AND SEE IF WE GET A SOLUTION QUICK:

http://us.battle.net/d3/en/forum/topic/6933876255
Reply Quote
Posts: 1
same here omg.. i tried everything and nothing seem to help, where blizzard? Can we help this issue, obviously this isn't isolated report... help!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]