Diablo® III

Mac Diablo III cannot play in China

I have Mac and Windows Diablo III installed on my two laptops.
Both of them are playable in U.S. (connect to U.S. Server)

When I move to China, Diablo III on my Mac cannot be launched.
After I click Play button, Diablo III freeze at logo screen.

but my Windows Diablo III is playable and good.

Could you help me on this?

Thanks.
Reply Quote
Posts: 8
Hello,

I am having the same problem! I also live abroad in China and I have both Mac OS and Windows 7 installed via bootcamp. I had no problem playing D3 before the 1.0.4 update, however. Once I updated, once I click play on the launcher it just freezes. Why is this? I think the development teams needs to become aware of this problem and seek a solution.
Reply Quote
Blizzard Employee
Posts: 14,784
Thanks for the report.

@okpoj, does this only happen on the OS X side of your Mac?
Reply Quote
Hey Machkhan,

I've done some testing, and apparently China has recently BANNED Diablo 3 for some reason...I used to play in China on the US servers no problem. Now with the release of 1.0.4 I cannot connect to the servers on the Mac OS side or via bootcamp. However, I ran a VPN on both operating systems and I am indeed able to connect to the servers. However, even with my high speed internet, playing d3 through the VPN renders the game unplayable, the VPN just slows down the speed too much.

I have to assume my findings are correct... Do you have any idea as to why China would ban Diablo 3? It looks like I will not be able to play the game I've been waiting a decade for now.. Beyond frustrating.
Reply Quote
Hello,

I am also having the same problem. I moved to china for University, I dont have boot camp for windows on my mac. I tried launching Diablo 3 but it freezes and after several minutes I got this message:
"Diablo III was unable to initialize a streaming connection, which is required to download, patch, and repair files. Please check your connection settings."

Hope you can help,
Thanks.
Reply Quote
@okpoj, I don't think they banned it without the following:

a: hearing about it in the media
b: having pc players being banned also.

I think it's just a mac issue.
Reply Quote
Well..it's not a mac issue because I have the exact same problem when I try to run it on windows bootcamp. However, both mac AND bootcamp will launch the game once I have my VPN on..just the VPN slows down the connection too much to play. This didn't happen before patch 1.0.4.
Edited by okpoj#1927 on 9/11/2012 2:17 AM PDT
Reply Quote
i have this issue which comes up for almost 3 weeks for now. "Diablo III was unable to initialize a streaming connection, which is required to download, patch, and repair files. Please check your connection settings"

can you help. thanks
Reply Quote
me too have the same issue here in china, just tried it on a another mac with boot camp using Windows XP and it worked with no problems. the connection i have is 10 mbit so no problem with the internetts. I was able to run the game a few weeks ago om my mac, and managed to play a little on 1.0.4 but after a few days it just would not run. get the same message as the rest of u guys.

i dont know if blizz as gotten reports form other people trying to run the game on a mac here in china. chinese people tend not to use mac OS...

me too need help... thanks!
Reply Quote
Blizzard Employee
Posts: 14,784
Did you try removing the Diablo III.mfil file and see if it helps? This is located in /Applications/Diablo III directory. Some users reported doing this resolved the issue.
Reply Quote
LOL!

removed the Diablo III.mfil and it startet right away!! awsome stuffs! 3 weeks of frustration was just lifted of my shoulders :D

TYTY mr. Machkhan!
Reply Quote
This one works for me.
I am using windows 7 64bit.
Reply Quote
I had this problem before... It was suggested I use Google public DNS and it worked.

https://developers.google.com/speed/public-dns/docs/using

Hope this helps...
Reply Quote
10/04/2012 10:28 AMPosted by Machkhan
Did you try removing the Diablo III.mfil file and see if it helps? This is located in /Applications/Diablo III directory. Some users reported doing this resolved the issue.


yes,this is the way to resolved the issue.i got it.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]