Diablo® III

Help... Can Not Install Diablo 3...

I stopped playing diablo 3 awhile ago and recently built a new computer and thought i might try diablo 3 again.

Every time I try to install Diablo 3 I get the error "Your Operating System Does Not Meet The Minimum Specs For Diablo 3"

Which is confusing since I meet all the required specs, here is my system specs.

Operating System: Windows 7 64 Bit, completely up to date with all "Important" and "Optional" items from the control panel, windows update. I performed these updates after I received the message about my operating system didn't meet the required specs. Updates took a few hours as there where many but all are applied now and still same error.

Processor: i7-3770k @ 3.5GHz
Video Card: EVGA 680GTX FTW edition
Ram:Corsair 16GB
Motherboard: Asus Sabertooth z77
SSD: Vortex 3 256gb

I have tried running the installer in Admin mode but same issue.

I have a complete backup of my last HDD before formatting and tried to launch Diablo 3 from those files (on another storage HDD, now using a SSD as main), the launcher updated the game first and then when I click "Play" to start the game it shows the diablo skull/splash (loading) image but then that disappears and does not load anything, nor show any error.

tried updating video card but already had latest drivers.

I am lost as to why I am getting this "Operating system does not meet min specs" error.

What can I try?

Thanks
Edited by Plague#1396 on 9/8/2012 6:26 PM PDT
Reply Quote
Just want to add that I currently have no additional firewall or antivirus and the only apps i have running are; Desktopfusion, skype, hamachi and air video.

System was formatted only a few weeks ago so I have no junk on here yet.
Reply Quote
I have the exact same problem with a computer from a friend. Im trying to solve it with teamviewer but no succes sofar. He build a up2date pc so that problem is pure bull!@#$ but ok.

Ive been searching abit and may i ask your using service pack 1 for windows 7?
Reply Quote
Yes I service pack 1 is installed, it was part of the large group of updates installed through windows update manager.
Reply Quote
I have a bunch of recent games installed at the moment and they all work perfectly, the only game having issues is diablo 3.
Reply Quote
Have you tried any of these? Do one at a time and see if corrected.

1:
Go to Control Panel > Administrative Tools > Services
Scroll down and find “Secondary Logon”
Right Click > Properties
Change it from ‘Disabled’ to ‘Automatic’

2:
Launch the installer (while launched go ctrl+alt+del)
Right Click Diablo 3 and go to process
Right Click Agent.exe and open file location
You should be in a folder called Agent.954
Right click the Agent application in this folder and go to properties-->compatibility
*Uncheck run this program in compatibility mode*
*Check run as administrator*
Click show settings for all users and make sure nothing is checked

3:
Go to your installer and do the same thing you did to the Agent application (administrator, uncheck compatibility, nothing checked in all users)

4: In the processes section of Task Manager make sure the Agent.exe is not running.. if it is close it.
Now re-open the Agent application in the Agent.954 folder
Then open the installer..
Edited by Grenth#1130 on 9/8/2012 7:59 PM PDT
Reply Quote
Thanks Grenth for that,

So i stepped through the instructions you said and number 4 worked. I had to manually launch agent.exe from it's folder, simply changing the file to run in admin mode then relaunching the installer (after ending the "Agent.exe" precess) didn't work, I had to stop the process then launch it myself for it to work.

So now the installation works but I have another error.

When I launch the game it shows the loading "Diablo 3 Skull" image but then after some time it just disappears and all the diablo 3 processors from task manager are gone and the game does not load. No error message is shown.

Any ideas?
Reply Quote
I'm not sure. What you can do is paste a copy of your D3Debug.txt file found in the Diablo III folder, Make sure to edit out any text referencing your account name before posting it. Also post your DXDiag

Click on Start
Click on Run
Type in: dxdiag (In Vista/Win7, type dxdiag in the search field)
Hit Enter or OK

Click on the Save All Information button at the bottom, and create a dxdiag text file, and copy and paste it ALL here.

Omrakos (Tech Support) may see it sometime tomorrow and be able to assist you further.
Edited by Grenth#1130 on 9/8/2012 8:16 PM PDT
Reply Quote
90 Blood Elf Hunter
12115
I have the same problem, I had to reformat my computer and stupid me back when i downloaded Diablo 3 pre-release i didnt save the install on a external device in case i needed it again. I keep getting the error even though i know my PC has run it before and I know it still can. I downloaded the game client and everytime i try and install it gives that error. Here's my specs: (I didnt put it all as i didnt want to spam everything).

------------------
System Information
------------------
Time of this report: 10/17/2012, 19:54:45
Machine name: ANDREW-PC
Operating System: Windows Vista™ Home Premium (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.101014-0432)
Language: English (Regional Setting: English)
System Manufacturer: MSI
System Model: MS-7681
BIOS: BIOS Date: 03/02/11 10:58:35 Ver: 04.06.04
Processor: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz (4 CPUs), ~3.3GHz
Memory: 3060MB RAM
Page File: 1741MB used, 4609MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 10
DX Setup Parameters: Not found
DxDiag Version: 6.00.6001.18000 32bit Unicode

---------------
Display Devices
---------------
Card name: AMD Radeon HD 6800 Series
Manufacturer: Advanced Micro Devices, Inc.
Chip type: AMD Radeon Graphics Processor (0x6738)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_6738&SUBSYS_31001682&REV_00
Display Memory: 2287 MB
Dedicated Memory: 1013 MB
Shared Memory: 1274 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor: Generic PnP Monitor
Driver Name: aticfx32.dll,aticfx32.dll,aticfx32.dll,atiumdag.dll,atidxx32.dll,atiumdva.cap
Driver Version: 8.17.0010.1140 (English)
DDI Version: 10.1
Driver Attributes: Final Retail
Driver Date/Size: 7/27/2012 21:15:42, 931328 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Device Identifier: {D7B71EE2-2478-11CF-4671-0A11BEC2C535}
Vendor ID: 0x1002
Device ID: 0x6738
SubSys ID: 0x31001682
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_A ModeMPEG2_C
Reply Quote
86 Human Paladin
4505
THANK YOU SOOOO MUCH it finally works
Reply Quote
Thanks guy! Number 1 is what did the trick for me. Switching from disable to automatic... Thanks!!!!
Reply Quote
Hello,

I have the same problem with "Your Operating System..."

I did evrything until i got stuck at step 4 and the end of step 3

I check Run as Administrator and after I didnt get the part when you said " Do the samething with the installer"?

Help Please

[removed]
Edited by Omrakos on 1/3/2013 2:55 PM PST
Reply Quote
- Technical Support
View profile
Remove your email and other contact info!!! That is how hackers/scammers/phishing emails get to you..and it is half your login information. Just stick to your battletag if you have to post something.
Reply Quote
I had the same problem... however the fix for me was quite simple, After i re-installed my OS i found (after some digging around) that my computer failed to install the latest service pack.
The auto update failed to do this, Its a long shot but check your running the latest service pack for your OS.
Reply Quote
Run as administrator fixed this for me.
Reply Quote
cheers that worked bro! tnx allot!!!!
Reply Quote
90 Pandaren Hunter
11010
I have tried all the above and it still isn't working for me if someone can help me out
Reply Quote
90 Draenei Shaman
7490
This is retarded. I've been playing D3 since release on this desktop, just recently factory reset it and now it doesn't work. Same hardware, same software.
Reply Quote
This worked. Kudos. Thanks dude. I tried step 1 and 2 and then figured it out from there on. Great step through I actually learned you could go straight to the executable through the task manager lol.
Reply Quote
25 Pandaren Mage
5365
I am using Windows XP and have no options to run as administrator as it kinda already does that. But I too have this error. The service in step one is already running for me. Any other ideas how I may overcome this issue and get back to playing diablo 3?

[Edit]
I have installed Starcraft 2 and WoW successfully without any problems only installer that does it is Diablo 3
[/Edit]
Edited by Schoktra#1144 on 3/5/2013 12:30 AM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]