Diablo® III

Error 73 cant log in!

I can log in!!!!

Thank YOU!!!
Reply Quote
THIS FIXED IT FOR ME:

I'm on Win 7.

1. Deleted my battle.net cache files (less than 300MB)
-See here for doing that: https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc
-This link has a link to the Mac instructions as well

2. Opened game via normal launcher

3. Closed launcher after "Play" button appeared
-This step may not be necessary

4. Launched again, clicked play and logged in normally...took a bit to authenticate but worked.

Hope this helps,
Vol


Hmm it works. Thanks :)
Reply Quote
THIS FIXED IT FOR ME:

I'm on Win 7.

1. Deleted my battle.net cache files (less than 300MB)
-See here for doing that: https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc
-This link has a link to the Mac instructions as well

2. Opened game via normal launcher

3. Closed launcher after "Play" button appeared
-This step may not be necessary

4. Launched again, clicked play and logged in normally...took a bit to authenticate but worked.

Hope this helps,
Vol


This solution work for me. Thank ya.
Reply Quote
Hello,

It seems to be back up just log on and it will work.

Peace.
-G45T0N

And please blizzard, keep us informed....
Reply Quote
are overseas players still having connection issues? I still can't log in
Reply Quote
cannot log in as well.
Reply Quote
Allday i have had issues....logging in, trying to access AH, and random DC's. I wonder if Blizzard has any clue that weekends are the only real time some of us have to try and play this game.
Reply Quote
My problem is Error 37 ... ( Server congestion ) ... Can't log in . ( US Server )
Reply Quote
I'm getting 37 and 3006. Randomly chooses the error...only on US servers though. Asian and EU load up just fine.
Reply Quote
having problems too! (ERROR 3006) Americas Server
Reply Quote
WTB a refund!!!!
Reply Quote
cant log in T_T
Reply Quote
I get same error and 3006 too
Reply Quote
Still getting error deleting cache didn't fix it.
Reply Quote
YES there is a error 73 and i have it right now ..when i try to log in this message pop up
" There is a temporary outage of the battle.net service. Please try again later ( error 73)

YES BLUE , THERE IS A ERROR 73 AND MANY PEOPLE ARE GETTING IT NOW .... IAM ONE OF THEM ....

omfg , please fix it ASAP ...please
Reply Quote
THIS FIXED IT FOR ME:

I'm on Win 7.

1. Deleted my battle.net cache files (less than 300MB)
-See here for doing that: https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc
-This link has a link to the Mac instructions as well

2. Opened game via normal launcher

3. Closed launcher after "Play" button appeared
-This step may not be necessary

4. Launched again, clicked play and logged in normally...took a bit to authenticate but worked.

Hope this helps,
Vol

HEY who know , it work for me fine ,,, yeah baby , thank you ....
Reply Quote
Posts: 37
I have this problem now to, unable to login. Pretty annoying.
Reply Quote
94 Tauren Druid
11950
Posts: 28
Still can't log in. Error 73
Edited by ESCasati#1365 on 1/6/2013 8:49 PM PST
Reply Quote
Posts: 4
Same problem here...
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]