Diablo® III

Bizarre Problem With Battlenet + Steam

Yes, I know this is not a Steam forum, but I'm having a problem that seems to extend into multiple programs on my computer, chiefly Battle.net and Steam. I've submitted tickets, asked on Steam forums, asked on reddit, and so far no one has been able to help, so I'm hoping someone here can.

The short version: everything was working perfectly fine until yesterday. For some reason, Battle.net and Steam refuse to believe that I am actually connected to the internet. In BNet's case, I tried launching Diablo 3 and Starcraft 2, and neither one would actually fully load the launcher. They would say "Initializing..." indefinitely. For Steam, it would try to open the program, only to say "Steam cannot detect an internet connection."

Obviously, the fact that I'm here posting this is proof that I do in fact have an internet connection. I can still check email, watch Netflix and Youtube, dink around reddit, everything else I normally do, but BNet and Steam just will not recognize that I have an internet connection. I have used both on this connection before, so I'm not sure why yesterday they just decided to stop cooperating.

Here's the really weird part: this morning I took my laptop to a public WiFi spot. It connected just fine, and Battle.net AND Steam both worked fine. I then put my laptop in standby (did NOT shut it off), brought it back home, hooked it back up to the main network, and it continued working. I was still able to connect to BNet and Steam. Everything seemed to be fixed.

Then I shut down my computer. When I turned it on again later, the original problem was back. BNet and Steam won't recognize my internet connection.

So that's where I stand. I've done all the obvious fixes (uninstall/reinstall, reboot, virus/malware checks, etc). Reddit people way smarter than me have narrowed it down to either being an issue of closed ports (why the university would suddenly close them now, after a month of having them open, I don't know, but I'm scheduled to talk to tech support on Monday), or a DNS issue. I've Googled every DNS fix-it/tweak guide I can find, and done everything they said, to no avail.

Can anyone here tell me what the heck this is? Is it the ports? Is it the DNS? Is it something else? And what the heck can I do about it?

Thanks for any/all help! :)
Reply Quote
09/15/2012 07:46 PMPosted by Highres
Can anyone here tell me what the heck this is? Is it the ports? Is it the DNS? Is it something else?


could be one of all of those things. no one can tell u that but your network's admin

09/15/2012 07:46 PMPosted by Highres
And what the heck can I do about it?


nothing because u dont own the network you're connecting to.
Edited by Gör#1270 on 9/15/2012 8:02 PM PDT
Reply Quote
Same thing here, I have been playing on Battle.net servers and using steam for the past month and a half on my campus, and yesterday it did not allow me to run the launcher at all. So I tried all the fixes and nothing worked, so I tried uninstalling and re-installing. Well, once I uninstalled it, I could not install the game anymore, since it wouldn't allow me to connect to their servers. I have an open ticket with them, and they told me to do a few things with AVG, and I am in the process of trying to solve it, but I don't have high hopes. I actually have a hard copy of the game, but it doesn't allow me to install it because it still needs to connect to their servers. I am pretty sure we are having the same issue, so I can try and keep you posted if it gets resolved with my ticket.
Reply Quote
I would appreciate it. Thanks! :)
Reply Quote
its most likely because ur behind a vpn, a virtual private network, if ur both on a campus. its possible ur college is blocking or limiting ur connection because u've either used all ur bandwidth for the month or it detected that ur using too much bandwidth, or they put blizzard ip addresses on their "baddie" list because they have too many ppl connecting to it causing their network to lag or using too much bandwidth. so you're blocked until whenever their server resets u which could be hours, days, weeks, months, or even never; usually its a matter of hours or days or until a new month rolls over. at least thats how my campus worked. in either case, there's nothing u can do about it. ur campus is limiting u to what u can access and it chose blizzard.

all u can really do is make sure ur connected to ur campus network properly. open internet explorer, or whatever browser u use and make sure ur logged into by making sure u can browse web sites. its best to either clear ur cache or go to as web site that u've never been to before to make sure its not jus picking up a cached site, then try reconnecting to d3.
Edited by Gör#1270 on 9/16/2012 5:43 AM PDT
Reply Quote
Gor is correct, I had just made contact with my campus' OIT department, and that is what they said was the issue, for the most part.
Reply Quote
90 Blood Elf Warlock
4775
I have this exact problem but I've changed all the DNS's and Forwarded all my ports.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]