Diablo® III

Diablo 3 Slow / Choppy/ Low FPS

85 Gnome Warlock
5610
I've tried everything, I've tried new video cards, new OS, your game is broken.

Diablo 3 is not working correctly. Thousands are complaining about the choppy / slow fps.

I do not need to post you my computer stats due to the fact my pc cost me 3 grand and runs perfect.

Your game is broken and you don't need me to tell you how to fix it, that is your job. So please, just figure out what the heck is wrong, fix it without telling us, then tell us all we are trolls. What ever works ok?
Reply Quote
85 Gnome Warlock
5610
Oh now I see your sticky... Yes the prefetch HD issue is bad. Please fix this soon or refund us :) Your game is barely ' beta ' quality. Imagine buying a car with no radiator and missing a wheel. I would get a quick refund, no?

Three performance-related issues in Diablo III seem to be centered around using the Vsync setting in the in-game video options, disk asset loading stutters, and a possible overheating issue.

Vsync: Vsync stuttering is normally caused by a machine being unable to maintain 60fps, falling behind and then alternating between 30fps and 60fps. When this is the cause, the player may want to limit the frame rate to 30fps, or reduce system and graphical settings. Ongoing optimizations by the developers will also help on this front.

Disk loading stutters: We’re working on the disk asset loading stutters as well. In an upcoming patch, some of the prefetching in the game is being changed which should help with the stuttering.

Overheating: There are some people having what appear to be video driver resets leading to long pauses as Diablo III reloads assets and then resumes playing. We're working to reproduce the issue internally. For now, we believe it could be due to the video card (GPU) overheating. Many users have addressed this on their own by limiting the frame rate and underclocking their GPUs.

The developers are making incremental improvements to address these issues. These will be rolled out across future patches.
Reply Quote
84 Tauren Paladin
970
I've tried everything, I've tried new video cards, new OS, your game is broken.

Diablo 3 is not working correctly. Thousands are complaining about the choppy / slow fps.

I do not need to post you my computer stats due to the fact my pc cost me 3 grand and runs perfect.

Your game is broken and you don't need me to tell you how to fix it, that is your job. So please, just figure out what the heck is wrong, fix it without telling us, then tell us all we are trolls. What ever works ok?


Game runs fine on my $500 PC...sometimes, you don't get what you paid for.

In any event, Blizzard has already acknowledged some issues with 1.04 causing additional lag, and if I'm not mistaken, they have implemented some solutions on the PTR (certains areas, including the sewers in A2 and other water heavy areas have seen tremendous improvements).
Reply Quote
Hi! I was running the game with the same problem till yesterday. Try this:

Ati Catalyst > Preferences >Standard View (I couldn't find this option in advance view)

Then:

Ati Catalyst > Gaming > Gaming Performance > Standard 3D Settings > UNCHECK: Use Custom Settings > Scroll to Optimal Performances

Give it a try. DO NOT activate Triple Buffer in OpenGL Settings or the Standard 3D settings will turn back to custom settings once more.

If is not good, I'll post the rest of my settings.
Reply Quote
Thousands are complaining about the choppy / slow fps.

...and starting yet another thread with zero information was supposed to...do what exactly?

There's already a lengthy thread on this with many trying to provide useful, actionable feedback. Please, contribute to its resolution or get a refund and go buy an Xbox.
Edited by Rolo#1588 on 10/2/2012 11:12 AM PDT
Reply Quote
90 Human Death Knight
10705
were did u find these settings? i cant find them anywere
Reply Quote
01/04/2013 11:22 AMPosted by Orochidiau
were did u find these settings? i cant find them anywere


control panel>Appearance and personalization>Adjust Screen Resolution>Advanced Settings>Intel(R) Graphics and Media Control Panel>Graphics properties>Advanced Mode>3D>3D Preference. There you go
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]