Diablo® III

Item Tooltip not showing?

I recently opened up D3 to start playing where I left off the night before but I noticed that the tool-tips for items mysteriously stopped working. When I hover the mouse over any item it doesn't do anything. If I click the item and place it back in my inventory it then pops up what should have shown upon the hover. It's really weird since I've made zero changes to anything on my mac or on my game settings. I've noticed as well that clicking on items like waypoints or shrines is extremely difficult and requires a few extra-persistent clicks. It's a really frustrating thing and has pretty much rendered the game unplayable. I've messed with the settings to no end, done a game reset, switched my mouse and nothing works. From what I gather a few people had this issue back in June but it seemed to be on Blizzard's side as it was across WoW, SCII, and D3 and randomly fixed itself.

I've had the disappearing mouse cursor happen a couple times in the last week but that was fixed by just relaunching the game. I'm not too sure what can be causing it. I've tried the game in Fullscreen, windowed, windowed-fullscreen and it's all the same.

Specs:
Processor 2.4 GHz Intel Core 2 Duo
Memory 4 GB 1067 MHz DDR3
Graphics NVIDIA GeForce 320M 256 MB
Software Mac OS X Lion 10.7.4 (11E53)
Reply Quote
Support Forum Agent
Did you try to rebuild the game caches and see if this helps in anyway?

Rebuild the Diablo III Cache
    1. Navigate to /Applications/Diablo III/Data_D3/PC/MPQs and delete the Cache folder.
    2. Then, navigate to Users/Shared/Battle.net/Agent and delete the Agent.db file.
    3. Run the Diablo III Launcher and let the game update it's files.
    4. Press Play when you see Game is up to date
Reply Quote
I got really excited for this possible solution but I got nothing. I even uninstalled the game last night and that still didn't produce any results. What I find bizarre is that I made no game changes or any changes on my mac. It was fine at midnight and then I logged in like 8 hours later in the morning and during gameplay it just crapped out. Any other suggestions?
Reply Quote
Here's another interesting screw up that has now happened. "Show item tool tip" key binding is now greyed out and does not allow me to modify it (it's currently grayed out but CTRL is active on binding 1). Also, when I click an item in my inventory like I previously mentioned, it shows the tool tip when I put it down. Now I've noticed that when I click the item and move my mouse, the item doesn't appear to move until I click back down and it suddenly snaps to the new location. If I want to move an item I essentially have to do it blindly.
Reply Quote
SOLUTION!!!
Apparently there is a problem with the Microsoft Intellimouse line-ups recently and the driver from Microsoft needs to be installed as it adds more functionality into the OSX preference panel. GOD THAT WAS FRUSTRATING!!!
Reply Quote
Support Forum Agent
Thanks for letting us know the results.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]