Diablo® III

Unable to Expand Diablo III Zip.

I just purchased Diablo III from my battle.net account. After downloaded the mac zip file (because I am operating on a mac), I clicked to extract the file and I got this message: "unable to expand 'Diablo-III-Setup-enUS.zip" into "Applications" (Error 2 - no such file or directory")

Can you please help?! If this doesn't work, I want a refund!

Thanks
Reply Quote
Support Forum Agent
Hey Fadil,

I tried this on Safari, Chrome and FireFox for Mac and it worked fine. Can you try a different browser?

As far as I know, this only happens when the download is not complete and then you try to open the file.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]