Diablo® III

Unequippable created item, no error shown.

Wizard, Act 1
Character level 11
Created shoulders with help of disassembling magical items by blacksmith.
Item has also level 11.

Problem: if try to equip(drag-and-drop or right-mouse-button) it is not equipped and stays in backpack. No error messages occur. Tried logging off and in - problem persists.

Currently item is in character's backpack.

Please advise, what is done wrong from my side?

Thank You in advance.
Reply Quote
I am having the same issue. Crafted a pair of pants for my Demon Hunter. I originally crafted them a level early and left them in my backpack for when I leveled up. When I did they would not equip. Makes the sound and gets greyed out but then just stays in the backpack.
Reply Quote
Strange, but I equipped my item on 12 level without issues. and I can put it on and remove it as any other item.
Maybe this is some level-tracking issue of items(maybe needed level is a bit higher, but level's are integer-values and items created have some soft of floating-point value)
Reply Quote
Same thing just happened for me haha

I just had to gain another level and all of a sudden the item worked fine. The requirements on the item are definitely off.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]