Diablo® III

Left Mouse Button + Archon = Broken


Pre 1.0.5 I ran a setup with Archon being my left mouse click and shock pulse being my right mouse click.

When Archon was off cooldown, I could left mouse click to move around and not activate Archon. In fact, I had to use Shift + Left Mouse Click to activate Archon which worked well for me because I put another level of intent into my key presses.

Since patch 1.0.5 Archon now activates when I try to walk and it is off cooldown. When I do not want to cast archon and I just want to move, it casts archon.
This has become game breaking for me, I am not enjoying not having Archon when I want it.
Im having the same problem. ***Blizzard please please fix this asap***, cant use archon anymore, as there are no way i can change the skills around. No armor/buff skill can be put on left mouse button :(

How about 'force move' doesn't that fix the problem... ?
Not just a major issue, big game breaker. If archon is on cooldown, you cant even open vendors or move in and out of dungeons, open treasure chests or some times the stash.
I was using same setup and it is a game breaker for me as well!!!

Also note that :
  • When you appear into a game the first mouse click activate Archon.
  • Archon also activate when I tried to open the cemetery gate in act 1.
  • This is non-sense!

    While fixing that it would be awesome to be able to separate primary skill and move / interact and assign them to different button. I truly believe that a lot of peoples would appreciate, the one button for everything is just error prone.

    People adapt because they can't change it, but I already saw a lot of posts and NO the force stand and move doesn't solve, it's merely a ugly patch! Forcing people to monkey on keyboard isn't a solution, having to press two button everytime single time you want to attack with primary without moving!

    While having another button to move only is not bad but it doesn't interact, would be great if it could be change to interact with an option so people can choose!

    I want to be able to move / interact with my first mouse button and I want it to never attack monsters so I can ran from monsters WITHOUT having to use yet another button to move only.

    I want to attack with secondary mouse button, because it stand still I don't have to press yet another key to attack without moving!
    Edited by novacrash#1515 on 10/17/2012 8:59 AM PDT
    Yes please fix this, it is a big game breaker. After some testing, seems its not just archon thats effected it just has a long cooldown and lasts awhile. Other spells also have this issue. But it does effect archon far more and it is a big game breaker for us Wizards.
    Edited by Xeonrf#1461 on 10/17/2012 8:02 AM PDT
    Has there been any acknowledgement of this being an issue?
    Edited by Scruffy#1197 on 10/19/2012 1:54 PM PDT
    Has there been any acknowledgement of this being an issue?
    Blizzard Employee
    Posts: 2,130
    We don't bump here.
    This topic is locked.

    Please report any Code of Conduct violations, including:

    Threats of violence. We take these seriously and will alert the proper authorities.

    Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

    Harassing or discriminatory language. This will not be tolerated.

    Forums Code of Conduct

    Report Post # written by

    Explain (256 characters max)