Diablo® III

Diablo 3 not responding after patch

same issue here. stuck on diablo skull. macbook pro retina 2.3gh. latest macos x. i was able to play the game on my win 7 64bit asus notebook. when i installed the game to mac and hit the play , diablo skull appears and blizzard launcher does not respond. uninstalled reinstalled. deleted the mfil deleted battle.net folder . still the same problem.
Reply Quote
Support Forum Agent
Posts: 14,784
I've seen this happen to players who are from the Turkey area. It appears to be a DNS issue with some ISP's. Are you playing from here?

As a simple test, try switching your DNS to Google's Public DNS server to play for a bit.
Edited by Machkhan on 1/15/2013 12:58 PM PST
Reply Quote
Haven't tried the DNS fix but I'm also not in Turkey so who knows. Definitely having the same problem as others in this thread and so far nothing (from deleting the mfil file to re-installing and everything in between) has worked. I've had a support ticket open for about a week but haven't been able to find a fix. I'm sure it's not my iMac since it always ran D3 great and runs everything else without any problem at all.
Reply Quote
yes i m playing from Turkey but i m already using google dns ): the game only worked once after i reseted game preferenes at the launcher. but now nothing works for me. i tried everything listed above

deleted game reinstalled
deleted folders in the shared folder
deleted mfil file in the diablo 3 folder
reset game preferences
changed dns
deleted cache

still i cant play
Edited by abstruse#2778 on 1/16/2013 12:56 PM PST
Reply Quote
Same problem, Application Not Responding after clicked "PLAY" button
macbook pro 13 late 2011
os x 10.8.2
already did these stuff:
deleting Diablo III.mfil file
deleting battle.net and blizzard folders under Shared folder
run repair tool
check that using google dns
reset game preferences

still not responding :(
Reply Quote
dont know how but my game is working now.
Reply Quote
I don't really know what I did. But it worked. Someone who have the same problem, can do the same things in the same order. :)
1> open diablo launcher
2> reset game preferences
3> delete Diablo III.mfil file
4> click PLAY

then, it works
Reply Quote
Posts: 4
Mine still doesn't work after doing what you did
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]