Diablo® III

Resolution Scaling Problem

This has been a problem for a while. Since the first big patch you guys put out, the way the game scales has been impossible to play.

I want you to read this, because this is not just a Diablo issue but a Blizzard issue

http://us.battle.net/sc2/en/forum/topic/6606363101

These are the problems that I am having with both games. The only difference is before this patch, I was able to bring down my desktop resolution so it could scale down. Now I wont scale at all and it is impossible to micro. I cannot be forced to move my mouse from corner to corner of my mousepad to micro my character. Here is some advice, SC2 WOL works perfectly, whatever has been done with the resolution there is how it should be. WHEN YOU GO TO A LOWER RESOLUTION THERE IS LESS MOUSE MOVEMENT REQUIRED AND THE CURSOR GETS BIGGER. Now in HOTS and D3 this is not the case anymore and it is literally impossible to play. It is so bad that I will not buy another Blizzard game until this issue is fixed. All my info is in the thread above and something needs to be done because 27" iMac users are suffering because of this. When you cannot use the pivot of your wrist to micro and have to use your whole arm, you cannot be competitive and will be more frustrated than anything. Please figure out the fix for this, there is something being done to these two games that similar.
Reply Quote
Support Forum Agent
I think I understand this a bit more. This may be relating to the display mode change.

Read more about this here: http://us.battle.net/wow/en/forum/topic/6471447232#4

This is not implemented in WoL yet, and It was semi active in D3, but it was capped at the desktop resolution and not the native resolution.

This is because changing the in-game resolution does not change the whole OS resolution like before.

Are you able to try the workaround to disable the change? Try to type this in the Terminal:

defaults write com.blizzard.diablo3 DesktopModeIsDefault 1
Edited by Machkhan on 10/17/2012 1:54 PM PDT
Reply Quote
I think I understand this a bit more. This may be relating to the display mode change.

Read more about this here: http://us.battle.net/wow/en/forum/topic/6471447232#4

This is not implemented in WoL yet, and It was semi active in D3, but it was capped at the desktop resolution and not the native resolution.

This is because changing the in-game resolution does not change the whole OS resolution like before.

Are you able to try the workaround to disable the change? Try to type this in the Terminal:

defaults write com.blizzard.worldofwarcraft DesktopModeIsDefault 1


By this you mean it will not change the resolution if you are in windowed mode, correct?. If you are in fullscreen, then the game SHOULD be able to change the resolution all the way up to the highest supported native resolution. The OS will then change the resolution for that context, and if you tab out back to the desktop then it will switch resolutions back to your desktop resolution to preserve your desktop environment. Tabbing back into the game will move the resolution back to the one set for the game's graphics context.
Reply Quote
Support Forum Agent
Yes.
Reply Quote
I just copy pasted that in my terminal but it didn't do anything after I opened the game.
Reply Quote
Support Forum Agent
Sorry I corrected the terminal input. Try this:

defaults write com.blizzard.diablo3 DesktopModeIsDefault 1
Reply Quote
Just tried that and nothing changed.
Reply Quote
Ok, it worked but it is only if I changed my desktop resolution. Thats good enough thanks, I can play again. I would really like it though if there was a way where I didn't have to switch my desktop resolution but at least its back to normal
Reply Quote
Support Forum Agent
This is an intended change. I'll provide that feedback up to the team for review though and see what they say.
Reply Quote
Also, I tried typing this in for the sc2 hots beta:

defaults write com.blizzard.StarCraft II Beta DesktopModeIsDefault 1

This is the message I got:

2012-10-17 17:27:55.359 defaults[4665:903] Unexpected argument DesktopModeIsDefault; leaving defaults unchanged.

I am still trying to figure out a way to get HOTS beta back to normal. The name of the file that I open up is StarCraft II Beta and the name of the folder is StarCraft II 2012 Beta. I don't know if you have any incite on this but if you have any idea on this let me know
Reply Quote
Support Forum Agent
10/17/2012 02:31 PMPosted by SiCkXecutor
defaults write com.blizzard.StarCraft II Beta DesktopModeIsDefault 1

You won't be able to do it with spaces like that. Let me experiment a bit.
Reply Quote
Support Forum Agent
com.blizzard.starcraft2.plist

Try:
defaults write com.blizzard.starcraft2 DesktopModeIsDefault 1
The thing is, the beta shares the same preference files as the live game.
Reply Quote
HOTS WORKS NOW THANK YOU SO MUCH!!!!!!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]