Diablo® III

Fullscreen resolution problems

Since 1.05 came out im having troubles setting the resolution for fullscreen mode to where there are no black borders and its not blurry. Im using a 13inch macbook pro which is connected to a monitor and the monitor is 720p. I tried setting it in d3prefs.txt but that didn't seem to work.
Reply Quote
Support Forum Agent
I don't think there should be any black borders...

Can you describe this more, or take a screenshot?

Can you also post full system specs?

    1. Launch Diablo III.
    2. Put Diablo III into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information: http://i49.tinypic.com/33njnzn.png
    4. Paste the contents of the copied system information here (Command-V)
Reply Quote
Software:

System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
64-bit Kernel and Extensions: No
Time since boot: 14:04

Hardware:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro7,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP71.0039.B0B
SMC Version (system): 1.62f6
Sudden Motion Sensor:
State: Enabled

Graphics/Displays:

NVIDIA GeForce 320M:

Chipset Model: NVIDIA GeForce 320M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x08a0
Revision ID: 0x00a2
ROM Revision: 3533
Displays:
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Mirror: On
Mirror Status: Hardware Mirror
Online: Yes
Built-In: Yes
DELL ST2421L:
Resolution: 1280 x 720 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: TPDTP23M2EUU
Main Display: Yes
Mirror: On
Mirror Status: Master Mirror
Online: Yes
Rotation: Supported
Television: Yes

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI

There isn't black borders in windowed mode only in fullscreen.. it was fine in fullscreen before the patch so I don't know what happened
Reply Quote
Support Forum Agent
It may be doing this because you your secondary display mirroring your main display. What happens when you don't have mirror mode on, or only using your main MBP display?
Edited by Machkhan on 10/18/2012 4:57 PM PDT
Reply Quote
Yeah the monitor is just for a larger picture of the macbook screen
Reply Quote
Support Forum Agent
Does it need to be set for mirror mode? Are you able to make the monitor the primary display and see if that makes it work?
Reply Quote
Yeah its in mirror mode.. the fullscreen mode was working fine before the update to 1.05
Edited by CarpeDiem#1308 on 10/18/2012 5:44 PM PDT
Reply Quote
Support Forum Agent
I mean turn off the mirror mode. Just for testing purposes.
Reply Quote
Oh, fullscreen mode is fine on just the macbook its just when I plug the hdmi into the monitor is when it messes up.
Reply Quote
Support Forum Agent
Try this Terminal (/Applications/Utilities) command when the game is closed:

defaults write com.blizzard.diablo3 DesktopModeIsDefault 1
Reply Quote
It worked, u da man
Reply Quote
Support Forum Agent
Looks like it was the result of the display mode change and the HDMI adapter. I'll send this feedback to the team.

All this terminal command did was revert back to the former display mode. You can read about this change in the known issues sticky here: http://us.battle.net/d3/en/forum/topic/6551285177
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]