Diablo® III

AH Amulet Buying and Not Receiving??

So a few hours ago I tried buyin an amulet on AH. I clicked buyout, it charged me the gold, and when I go to the completed tab Nothing is there. Although it lists that I bought it in the history it doesnt appear for me to send to stash. I didn't receive it. I then tried buying a pair of shoulders and legs and all worked fine. Was able to send to stash. Figured maybe it was a fluke and tried buying another amulet......once again same thing happened. Charged the gold, wasn't given the amulet. What's going on here??
Reply Quote
WTF both of them just now appeared..... Idk I guess lag? Idk why it only affected the amulets though.
Reply Quote
Posts: 21
I just bought some shoulders and had this same problem. Unfortunately, they haven't shown up yet.
Reply Quote
I just bought a wirt's leg. Same problem. I won the bid, didn't get the item and lost the gold. Still haven't gotten the item yet if it's lag.
Edited by Frumpy#1281 on 10/18/2012 10:18 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]