Diablo® III

Losing settings when I close then launch D3

As title says. I'm on a 2010 MBP (c2d, 2.4ghz)
Every single time I log in, I lose my settings such as:

-region (i play on NA, but logging in puts me to asia, and i have to pick NA THEN log again)
-resolution settings (it should be fullscreen windowed mode) when I log in, the resolution is funky and I have to click on "full screen", THEN click on "windowed full screen". It's OK after this.
-MP. I have to turn on "enable monster power" every time I log in.

These issues are annoying. Can anyone help? Thanks in advance.
Reply Quote
Support Forum Agent
Posts: 14,784
This sounds like a permission issue with the User Library. Have you ran permission repair to see if this helps?

Repair Permissions via Disk Utility
    1. Navigate to /Applications/Utilities/ and open Disk Utility.
    2. Select the hard drive the game is installed on.
    3. Select the First Aid option.
    4. Click on the Repair Disk Permissions button.

IF this doesn't fix it, it might be a permission of the file itself or the actual directory. A simple test of just creating a new administrator account and try to play would help see if this issue is related to user account permission.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]