Diablo® III

"Initializing" problem with latest patch

Posts: 2
Did you try this and see if it helps?

    1. Force quit any Diablo III, Agent and Blizzard Launcher processes in [url="http://us.battle.net/support/en/article/closing-background-applications-mac"]Activity Monitor[/url].
    2. Navigate to /Applications/Diablo III.
    3. Delete the D3Debug.txt file.
    4. [url="http://us.battle.net/support/en/article/repair-file-permissions-and-reset-folder-permissions-mac"]Reset the Diablo III game folder permissions[/url].
    5. Launch Diablo III.
  • If the game prompts to enter in your administrator username/password, hit Cancel.
  • If it doesn't it should load fine.
  • 6. Diablo III should load.


Did all this. Still having that "initializing" problem.
Reply Quote
Support Forum Agent
Posts: 14,784
Try these things:

Resetting permissions on the Diablo III folder
    1. Select the Diablo III folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items

Also, try deleting the Diablo III.mfil file from the Battle.net folder.
________________________________________________
https://battle.net/support/article/contact
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]