Diablo® III

Disconnected from game server.

I have the same problem as well. I have completely removed my router from the equation and it still happens. I've run my internet over wifi and wired with no change. Prior to November 17th I never had an issue like this. If fact I had played the morning prior to the server maintenance without any issues. Afterwards is another story. Today it was so bad I would disconnect shortly after connecting. I can join a game and for a few minutes everything is fine then I start lagging and 5-10 sec later it says I've been disconnected from the game server. I drop back to the menu screen and within a few minutes it says I've been disconnected form the server and drops to the login screen. Funny thing is during this time I can still message friends, even while I'm lagging in a game and while I'm in the menu screen waiting for it to drop me to the login screen. Seems to me the server just refuses to accept my connection. I dont even have to be in a game for it to happen. Just sitting at the menu screen it will drop me. My connection for anything other then d3 works just fine.
Reply Quote
I keep disconnecting from the games as well. Not sure what is going on here but hopefully it is resolved rather quickly.
Reply Quote
Same issue. been happening to me and everyone else at my house, roommate and friend who plays here too, since 1.0.5 came out.. No problems before that, its not my router either, I removed it and went straight from the cable modem, same problem. Makes it extremely frustrating to play. Btw, seems to be worse at night, I work during the day, but the few times I have had a chance to play earlier in the day it doesnt seem to happen as much.
Reply Quote
Posts: 28
This started happening to me less than a month ago and has gotten to the point where on my 4th stack i get booted. I got my ISP to reset my router frequency and nothing happened. I have reinstalled twice and nothing. Its something to do with battlenet and im getting sick of this. Im ready to quit this game all together. I cant even farm keys anymore because i get booted before 5 stacks. It doesnt boot me to log screen, just to character screen. It is ridiculous. It started happening after patch 1.05.

BLIZZARD PLEASE HELP IM READY TO GIVE UP ON THIS GAME.

ALSO

I use LAN not wireless.
Edited by TRGRyGuy#1468 on 11/19/2012 8:49 PM PST
Reply Quote
I'm getting this too, but generally when I'm on my ww barb. I heard someone say there's some kind of bug with that?
Reply Quote
I've been getting "removed from game" as well (with the banner to upgrade in the upper-right corner) on my WD, and my wife has gotten the same issue on her monk, so it doesn't seem to be class-specific. I have an authenticator on my account, so I'm not being kicked due to hacker logging in to my account. It seems like the game occasionally thinks I'm playing a trial version. Hoping for a fix soon.
Edited by WaterWolf#1627 on 11/29/2012 1:18 PM PST
Reply Quote
Posts: 27
Happened to me too quite a number of times already.
I think it has something to do with the new patch as well as the internet connection.

Never experienced being disconnected this frequent before. I now disconnect every 10-20 minutes. Error 3007 or just says something about Battle net server time out.

Must be a bug in the patch.
Reply Quote
Same thing here. Im constantly getting random disconnects after <20mins of playing. I normally run wireless, but I went Lan, no change. Disabled firewalls, no change. Closed down all background programs, no change. Uninstalled security crap, no change. Basically the games pretty unplayable for me right now, so hopefully this will be resolved soon.
Reply Quote
I've tried all the fixes, and nothing seems to work..
I lag a little every now and then, but for the most part the major problem is the complete disconnect. I'll be playing just long enough to get my NV and then disconnect. It never fails to come right before or after my NV.

I get error code 30003? i forget how many zeros.. claiming it can't connect, but.. i have internet or else i'd not be posting this?

I'm runnin' comcast.. it's getting pretty annoying, lol.
Reply Quote
I was disconnected 5 times last night but was luckly playing with a group which allowed me to rejoin without losing my NV.

This morning, I was completing a solo run and getting kicked out was enough to get me to stop playing. I lost my NV stacks twice in 1 hour and did not attempt to run it again.

I spent quite a bit of hours playing this game and decided to stop as that was too frustrating to continue without a fix.
Reply Quote
Hi there

My apologies for the confusion and frustration with this issue. We've looked further into this, and it looks like this is an issue that a lot of other people are running into with comcast as well.

It's not specifically comcast, but the carrier between us and comcast. We're currently trying to find a solution with the carrier to get all of this sorted out. But for the time being, if you've timed your disconnects at about an hour, I recommend saving and exiting the game before that time runs out. We don't want you to lose a hardcore character or miss any loot.

I know this is a bit tedious and frustrating, but know that we're trying to find a solution to this connection problem.

If you have any other questions or concerns, please feel free to contact us via this ticket, or phone.
You can find our contact info here: (http://us.battle.net/support/en/article/contact)

Thanks again for your patience and continued passion for our game,

Patrick R.
Customer Support
Blizzard Entertainment
www.us.battle.net/support
Reply Quote
Contacted Blizzard, and thats what they told me.
Reply Quote
Hi there

My apologies for the confusion and frustration with this issue. We've looked further into this, and it looks like this is an issue that a lot of other people are running into with comcast as well.

It's not specifically comcast, but the carrier between us and comcast. We're currently trying to find a solution with the carrier to get all of this sorted out. But for the time being, if you've timed your disconnects at about an hour, I recommend saving and exiting the game before that time runs out. We don't want you to lose a hardcore character or miss any loot.

I know this is a bit tedious and frustrating, but know that we're trying to find a solution to this connection problem.

If you have any other questions or concerns, please feel free to contact us via this ticket, or phone.
You can find our contact info here: (http://us.battle.net/support/en/article/contact)

Thanks again for your patience and continued passion for our game,

Patrick R.
Customer Support
Blizzard Entertainment
www.us.battle.net/support


Not even with Comcast and that is happening to me... I am with Shaw (Canada) and is experiencing the same issue.
Reply Quote
Well after i sent support my MSInfo and such i did get some good feedback as to some problems that might help me out, unfortunately after i tried all of them i still do get disconnected.

It's possible my computer is part of the problem, i admit that. lol. I just don't have the money to keep it serviced professionally so i do what i can. And i have been having a few issues.

But if other people using comcast are also having disconnects it obv isn't only my computer. I hope something gets figured out, but for now i'm gonna try to play through my sisters net when i can. ;]
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]