Diablo® III

Fix the lag please

Since 1.0.5, big lag from 10 to 300 sec game freeze.
And when game is freeze I can acces to your forum without any problems.
Reply Quote
Lots of players reporting this today!
...I have lag too.
Reply Quote
The lag is just terrible. I was having latency spikes upwards of 1500 last night. Today, well, the game is just not playable. I would agree that this all seemed to start right after the latest patch.
Reply Quote
2606 msec latency.
Reply Quote
I've noticed that since the latest patch (after 1.0.5) I have been getting random changes from my lag bar. Starts out green then I'll be shooting and be it a stream spikes out or a shot doesn't fire then seconds later double fires I know it's starting. Lag bar drops to yellow and it's clipping lag for several minutes.

This seems to come and go; my internet is fine, this is not a time of day depedant occurence, and I play other online games where this is not an issue. It also was not happening before this latest patch.
Reply Quote
I have been getting this same problem for about the last week or so. I'll start off the game just fine, then randomly I'll start get major lag spikes upwards of 1,500 ms. The game will skip around for a few seconds, sometime pulling me around the screen as if I never moved. Then everything freezes but me. I can tempest rush through a whole zone then all a sudden I get pulled back to the beginning of the zone and dead.
Reply Quote
i just started today having the lag issues. dont know why but, even when it shows green about 92 MS shortly after loggin into the gae world, abilities try to go off when pressed, no buffs etc show til 15-20 sec later if not more.

then if i happen to get to another area , the envoironment loads partially, and i end up coming to a flat line boundary unloaded , end up waiting 20-30 seconds, all of a sudden its like everything catches up again. i have also had it just freeze up where my character was not visible.
Reply Quote
I too have noticed the recent lag issues after 1.05. It didn't really start though till after the last couple rounds of hotfixes. My internet connection is fine, so it is on Blizzard's end. This lag reminds me of the early days of D3 when a lot more people were playing. I wonder if Blizzard has decided to remove some of the servers Diablo is played on in order to save money. It is highly unlikely this early on in the game's life, but nothing would surprise me at this point.
Reply Quote
90 Orc Warrior
6385
Game is unplayable. Tracert drops packets at ATT. Any fix on the horizon?
Reply Quote
Lag is totally random but when i speak to marchants or move items from my inventory, it's 100% freeze. And when game is freezing, chat is working ...
Reply Quote
yeah its getting worse. I had no issue before 1.5. Now my ping sits under 300 where it was 200 before and game disconnects...
Reply Quote
Bump
Reply Quote
I've just started having lag issues today. Can play for about 5-15 minutes with no issues, then I'll have a 15-30 second lag spike, and this just keeps repeating. Not even the beta had lag this bad for the most part, did something happen with the latest patch?
Reply Quote
bump
Reply Quote
I've got this problems since mi-october...

Sometimes at worse, I can play for 30 seconds, then I have to pause the game for 5 minutes !

My isp says that there are some problems with "Level 3", a very big company that manage part of the internet over the world...

Maybe it's the same for some of you... I live on an island near Australia and maybe the problems are multiplicated for me...

Anyway a friend had a solution for me and now my route to blizzard's servers is a little different now...
Reply Quote
I've got this problems since mi-october...Sometimes at worse, I can play for 30 seconds, then I have to pause the game for 5 minutes !My isp says that there are some problems with "Level 3", a very big company that manage part of the internet over the world...Maybe it's the same for some of you... I live on an island near Australia and maybe the problems are multiplicated for me...Anyway a friend had a solution for me and now my route to blizzard's servers is a little different now...


Hey

Where exactly do you leave?

Have you got problems with your new route too ?

Ou tu viens de calédonie et tu vas me répondre en fr ...
Edited by Mushu#2697 on 11/7/2012 12:09 AM PST
Reply Quote
i hope blue post help us.. can't play decent game almost a week.. i have done everything they told me to do.. but nothing change..
Reply Quote
Hi, i'm having the same thing here, without changing anything on my computer nor my router, i'm starting to be tired of this....
playing well then everything freeze for 30-300sec except my toon.
When i check the D3Debug.txt i get a lot of "Received pong with old sequence!" everytime this happen.
If blue could help us on this it would be great xD

@Mushu : i'm from caledonie but...fleme de faire du multilangue xD
Reply Quote
Lag is terrible the past few days.
Reply Quote
Hi, i'm having the same thing here, without changing anything on my computer nor my router, i'm starting to be tired of this....
playing well then everything freeze for 30-300sec except my toon.
When i check the D3Debug.txt i get a lot of "Received pong with old sequence!" everytime this happen.
If blue could help us on this it would be great xD


i have the same problem where i freeze for 10-15 seconds with the "received pong with old sequence!" line in my debug file.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]