Diablo® III

Items in real money AH failed and disappeared

When I tried to sell items in real money auction house yesterday and today, it always told me "Due to heavy system load your transaction request has not yet been resolved. Please keep this in mind as you consider additional transactions in the auction house. Check the completed auctions tab for information." Then it showed "Authorizing" on the item. But hours later, authorization failed, and the item came to my completed items. When I tried to send the failed item to my stash, it's gone. I cannot find it any where. Please help to solve this problem, and I want my items back.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]