Diablo® III

THE LAUNCHER------FIX BLIZZARD.

Been a few weeks now since 1.5 release and yet I can still not login without the stupid launcher downloading at 97-99.9%..... It's effecting my performance in game having this download constantly in the background and also causing crashes.... The latest happen just as a legendary dropped, VERY FRUSTRATING. Please figure out the source of this issue and address it.
This is my second post and the first one was ignored....

I'm running on Max OSX if this helps at all....
Reply Quote
- Technical Support
90 Human Priest
6120
Have you tried letting the launcher actually finish its job (downloading/building your cache) before you click Play? It is almost always wisest to let it finish before entering the game, for the exact reasons you're experiencing.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Reply Quote
Have you tried letting the launcher actually finish its job (downloading/building your cache) before you click Play? It is almost always wisest to let it finish before entering the game, for the exact reasons you're experiencing.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
I've done that 3 times, every time I delete my cache it come back and starts downloading again. Sometimes it will sit idle for 20-30mins at 99.9% and not download anything. Getting rather annoying.
Edited by Xcalibur#1814 on 11/3/2012 6:48 PM PDT
Reply Quote
- Technical Support
90 Human Priest
6120
OK. The next thing to try is delete the following files/folders:

/Users/Shared/Battle.net/Agent/Agent.db
/Diablo III/Diablo III.mfil
/Diablo III/Data_D3/PC/MPQs/Cache

Once done deleting those files, make sure all permissions are set properly in Diablo 3's main folder by doing the following:

1) Get Info (in the Finder) on the Diablo III folder.

2) Click the padlock icon and enter your password to authenticate yourself.

3) For the Everyone group, set it to Read and Write.

4) Click the cogwheel icon and select Apply to enclosed items. Select OK to confirm your action.

5) Close the Get Info Window.

Once that is done, run the Launcher again. Without the Diablo III.mfil file, it'll have to get a new one, and with no cache, it will rebuild it in full from scratch, and the deletion of the Agent.db file is to make sure there is no lingering Agent database corruption.

Let me know how that goes for you. :)

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Reply Quote
Support Forum Agent
Let us know if Tiapriestess suggestions help. If not, we'll look more into this.
________________________________________________
https://us.battle.net/support
Reply Quote
- Technical Support
90 Human Priest
6120
Xcalibur, could we get an update on your progress? I'd like to know if the problem is either solved or needs more looking into by S4d1k's team.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]