Diablo® III

Fix the god damn lag on your servers

as above - go die in a fire
Reply Quote
Posts: 3,729
View profile
it's not their servers. it's your connection.

mine works perfect
Reply Quote
seems to be pretty bad since 1.05 almost to the point of unplayable :/
Reply Quote
10/30/2012 12:36 AMPosted by Hi5
as above - go die in a fire


Go to general chat if you're going to speak like that you shall fit right in.
Reply Quote
haha I am agreeing with the OP, the lag is really bad lately. Net is fine can download adult material pretty fast to enjoy a nice slippery fap, but fap while playing Diablo 3 takes me way longer with the rubber (banding), constant disconnecting and being turned down for the initial intercourse when logging in....Fix please my little weinis needs fap time
Edited by BriztankNZ#6128 on 10/30/2012 3:35 AM PDT
Reply Quote
I have a Telstra cable, it drops out constantly. I don't blame Blizzard, it's the wankers at Telstra. And their curry tech support aren't the brightest bunch.
Reply Quote
10/30/2012 03:34 AMPosted by BriztankNZ
haha I am agreeing with the OP, the lag is really bad lately. Net is fine can download adult material pretty fast to enjoy a nice slippery fap

this pretty much sums up how we judge our internet speed haha
Reply Quote
Gotta love the word fap.
Reply Quote
Posts: 11
Not with telstra, but with telecom myself and I know several people getting in game lag this week and only this week, not a clue whats going on
Reply Quote
Rubberbanding is still there but with thread titles like this, you're more likely to be ignored.
Reply Quote
90 Pandaren Shaman
8965
Posts: 23
I feel that unless you live close to Blizzard, the lag is ridiculous. I can NOT play a single day without lag spikes every hour or less in Toronto canada. My internet is the fastest you can get and with great connection on other games, and my computer runs most games on ultra so its definitely their servers...they need to remedy this fast. Im not alone here.
Reply Quote
10/31/2012 04:18 PMPosted by Ashpool
I have a Telstra cable, it drops out constantly. I don't blame Blizzard, it's the wankers at Telstra. And their curry tech support aren't the brightest bunch.


I'm on telstra cable as well, as far as I know The connection in my region is fast and generally good, close to 100mbit bitrate and usually sits around 180-225 mms ping.
As for tech support unfortunately it seems while telstra has fantastic network they axed all the onshore tech support in favor of cheap offshore partners in india or phillipines, who follow a script and don't quiet understand how to talk about real technical issues. For example i once dealt with one that kept identifying my service as ADSL not cable until i got a hold of their escalations or supervisor. The technical support didn't understand CABLE and ADSL were different network technologies...
Reply Quote
11/17/2012 03:17 PMPosted by Calum
100mbit bitrate and usually sits around 180-225 mms ping.

I get 180 on the cheapest adsl2 unlimited plan available. I always thought cable would be better :(
Reply Quote
im getting really sick of watching my char bounce back 3 steps for every 4 i take while amongst monsters. you cant time skills to be effective at all
Reply Quote
Is it a time of day thing?

I live in regional QLD and have ADSL1 and have not lagged/rubber banded at all (except within the first 10sec of joining a game), however I am a shift worker and only play between the hours of 8am and 6pm. I pretty much play every day for a minimum of 4 hours. My ping is always 270-320.

When I first started playing I lagged heaps, turned out it was my wireless router, which surprised me because web browsing and other games did not lag and things downloaded fast.
Reply Quote
11/17/2012 03:17 PMPosted by Calum
I have a Telstra cable, it drops out constantly. I don't blame Blizzard, it's the wankers at Telstra. And their curry tech support aren't the brightest bunch.


I'm on telstra cable as well, as far as I know The connection in my region is fast and generally good, close to 100mbit bitrate and usually sits around 180-225 mms ping.
As for tech support unfortunately it seems while telstra has fantastic network they axed all the onshore tech support in favor of cheap offshore partners in india or phillipines, who follow a script and don't quiet understand how to talk about real technical issues. For example i once dealt with one that kept identifying my service as ADSL not cable until i got a hold of their escalations or supervisor. The technical support didn't understand CABLE and ADSL were different network technologies...


Oh man, I remember once, my cable kept getting drop outs (still does) I wasn't sure if it was our router, or on Telstra's end.

But this is how it went:

me: "I keep getting drop outs constantly"

support: "Did you reset your router?"

me: "Yes numerous times....."

support: "..........Did you reset your router?"

me: "I just told you, I have numerous times."

support "eh, ah, ........Did you reset your router?"

Useless bunch.
Reply Quote
Yes I have reset and power cycled and removed all devices from the line can you please check your end? thank you

support: "Did you reset your router?"
Edited by metaStatic#6741 on 11/18/2012 4:51 PM PST
Reply Quote
When mine was lagging I got so sick of it I went out and bought a brand new very expensive recommended router just to shut them up, rang them up again, unwrapped/opened the box while I was on the phone to them and still got the "Did you reset your router?"

I changed ISP's...
Reply Quote
Yes, the lag has gotten worse since 1.5..
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]