Diablo® III

Latency Issues since last maintenance

Posts: 1
Game has never had a problem until last major maintenance that happened just a few days ago. I think that is why anyways, im probably wrong lol.
My ping constantly is changing now. in town it does it less but in front of mobs I have a 2-3 second lag spikes that usually kills me because of the frames that are not showing up. I see me moving but the rest of the game is wating to catch up (my attacks are now looking like I am just swinging my arms while no effects show, all other units are frozen). it catches up and I can resume play for another for seconds before it does it again.. gave it a few days to see what is up. Been checking everything I know to figure this out and its got me stumped. HIGHLY ANNOYED =).
I use only a modem with an ethernet cord. OLD 3rd gen XPS dimension. runs like a champ. Nvidea 8800 gts.

I have now changed settings left and right in hopes of changing things to fix this. but I hadnt touched them anytime around when the problem started.

Thanks for the help
Edited by Radditz187#1188 on 11/20/2012 8:21 PM PST
Reply Quote
yeah same with me since last maintenance, never had any problems, now I just can't play D3 anymore.
Reply Quote
I'm getting it, too. These lag spikes are a real deterrent to playing.
Reply Quote
check this thread maybe it will help.

http://us.battle.net/d3/en/forum/topic/7200081077
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]