Diablo® III

I think I solved the constant HD stuttering

First and foremost, let's go over what I've tried in the past that didn't fix the stutters from hard drive asset loading:

Turning off shadows - Irrelevant
Messing around with pre-loading frames in NVidia - No change
Turning off indexing - Irrelevant
Moving MPQs to a flash drive - No change
Moving MPQs to a RAM drive - No change
Switching from 4 to 2 CPU - No change
Changing Hardware to 1 in prefs file - No change

But today I finally noticed something: My Avast virus protection and Zonealarm firewall are really nosy and always popping up when my hard drive does something. This led me to believe that it's possible that these two programs are interfering with the smooth asset loading of D3, so I disabled them, gave it a try, and noticed a substantial improvement in performance with hardly any skipping except initial loads. Give it a shot! Obviously you will want to be diligent about re-enabling them after you're done playing.

Here's the rest of my specs. No other funny business with MPQs or CPU or prefs file. All of that is default. Hope this helps. (For all I know, switching to Windowed Mode and maxing all FPS settings did the trick too.)

http://i.imgur.com/fSkvP.jpg

http://i.imgur.com/gjDgU.jpg
Edited by Mugwump#1573 on 11/26/2012 1:21 PM PST
Reply Quote
:)
Reply Quote
Thought I would post this fix on any threads that were about the stuttering issue becuase it was driving me absolutely insane!!! After trying everything I finally figured it out thanks to someone who posted something several months ago that turned on a lightbulb in my head...

His solution was this:

"I simply turned off real time protection on my anti virus software. (microsoft security essentials)."

Basically whenever the SDD or HDD was being accessed, real time protection was scanning them for viruses etc, and thus the game files were being accessed multiple times whilst they were trying to load in game.

Such a simple fix. Game is now 100% smooth with no stuttering at all.


I'm pretty sure this was my problem as well! I didn't have the exact same fix but basically I installed the game on my C:/ drive instead of my alternate internal E:/ drive I use for most Applications and now the stuttering is gone.

Wierd thing is I used to have it on that same drive and had no problems, all of a sudden when I come back to play again it was stuttering like crazy! So McAfee must have been trying to scan the files or something on the External hard drive as they were being accessed.

Regardless I re-intalled it on the C:/ drive and its fixed.
Reply Quote
12/08/2012 05:56 PMPosted by Ash
"I simply turned off real time protection on my anti virus software. (microsoft security essentials)."


interesting.
i will give this a try... though im not turning it off :p
it does have a place in there to exlcude files and locations as well as processes. ive done it before for RIFT because it was causing issues at one point.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]