Diablo® III

Constant disconnects

Hard wired connection, sometimes gets locked up on authenticating credentials and says I've been disconnected from battle.net.

I recently uninstalled and reinstalled because I was having issues even getting the game started after having the disconnect issues I'm currently having. I didn't play much in the past few months, not sure if a new patch created any issues.

Any help? As of now it's just locking up after being connected to battle.net. It also just gave me an Error 3005.

Thanks for any help
Reply Quote
Support Forum Agent
Sacuraf,

Could you try what's described in the following two articles please?

https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS

https://us.battle.net/support/en/article/deleting-battlenet-tools-folder-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS
Reply Quote
I did both of those yesterday prior to uninstalling. I can do them again now if you think it would help.
Reply Quote
Support Forum Agent
Sacuraf,

I'd like you to, yes. I need to know the state of the system when troubleshooting. I've no way to know what's transpired since you did a step yesterday.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]