Diablo® III

Comcast users - High latency since 1:00PMEST?

90 Night Elf Druid
11325
Posts: 3
Ever since 1:00PM EST my latency has been bouncing from 250-450. I talked with my friend who lives 5 minutes away, and he is having no issues whatsoever. I pinged a server in Jacksonville, and I got a 30. So I am thinking this might be a Comcast-Blizzard issue. Anyone else having problems?
Reply Quote
85 Worgen Druid
1235
Posts: 2
in jax as well, same problems...
Reply Quote
Same issues, South Florida
Reply Quote
90 Night Elf Druid
11325
Posts: 3
I forgot to mention, I'm in Orlando. It must be an issue with Comcast users in Florida. What's strange is that all other websites/services work just fine, but Diablo 3, and even the battle.net website are just crawling for me.
Reply Quote
90 Night Elf Druid
11325
Posts: 3
Ok, the issue seems to have resolved itself now.
Reply Quote
Palm Beach county, FL - same issue. Also a Comcast user.

So which one of you is going to phone this one in for the rest of us? ;)

edit - Seems to be a lot better at the moment.
Edited by imloungin#1165 on 12/5/2012 12:08 PM PST
Reply Quote
85 Worgen Druid
1235
Posts: 2
i see it come and go with lag spikes reaching 2000ms, whats the deal? its been going on all day...
Reply Quote
Comcast NorCal also having problems.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]