Diablo® III

Diablo 3 stops responding after clicking Play

Hi all,

I took a break from the game for a few months. When I tried to log in today it kept getting stuck on the logo that appears after I click "Play" from the launcher (The program stops responding immediately, and not after a period of time)

Could someone please inform me of a solution?

Thanks :)

P.S This problem has also occurred before, but would usually be resolved within a few tries.

http://imageupload.org/thumb/thumb_244254.png
Edited by Imperius#1404 on 12/5/2012 4:32 AM PST
Reply Quote
Update:

I managed to solve the problem by deleting Diablo III.mfil from the installation folder

:)

Solved the same problem for my friends as well.

Please lock this thread
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]