Diablo® III

To nvidia GTX users

I've been having some trouble with d3 since i bought my new beast of a pc, it runs the witcher 2 on max settings while staying nice and chilly, but overheats playing diablo on the lowest settings.

I came across a thread mentioning a conflict with certain motherboards using Realtek HD Audio so decided to investigate a bit further.

After disabling the Realtek HD Audio Manager in msconfig (Start->msconfig->Startup) and restarting my machine, my temps while playing diablo 3 immediately dropped by 20-25 degrees and i've yet to experience another crash or graphical glitch.

This may be old news, but i had to share my find incase there was anyone else like me left scratching their head over D3 performance issues on high end machines.

Specs:
water cooled intel i7 2600k 3.4ghz cpu
nvidia gtx 570 x 2 sli
2x 120gb ssd in raid 0
16gb ram
(i don't have my mobo model on hand, but it wasn't cheap)
Edited by ALittleHazey#1268 on 12/11/2012 12:13 AM PST
Reply Quote
Support Forum Agent
Posts: 37,069
ALittleHazey,

It's not going to help but I run pretty much the same hardware at home:

Water cooled Intel i7 2600k @4ghz cpu (slight overclock)
Nvidia GTX 670 x 2 sli
2x 120gb Vertex 3 SSDs in raid 0
8gb ram
Realtek on-board sound used half the time, Corsair Vengeance 2000 headphones the other half
Asus P8P67 Deluxe motherboard

and I have no cooling or performance problems at all.

What component temps are you seeing rise with the sound enabled?
Reply Quote
12/11/2012 12:45 PMPosted by Omrakos
What component temps are you seeing rise with the sound enabled?


Thanks for the reply, with realtek audio manager enabled my gpu was averaging 20-25c higher temps according to evga precision, confirmed by my whirring fans.

It shot up as soon as i opened d3, rising on the login screen, getting dangerous on the menu screen and failing during extended sessions, and especially during multiplayer.

After making that one simple adjustment im on max settings and just slightly above my idle temp. To be clear i'm not playing without sound, I just shut off that particular component.
I have no idea why it only affects certain games, i'm not that tech savvy, i just thought i'd share the fix.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]