Diablo® III

1.0.6a and Error 3007?

(Locked)

same, Melbourne Australia, getting error 3007.
Same here in NZ
same, brisbane australia on cable connection

this is bs and is = 2 abuse.

ty 4 fix in advance!
aus as well with 3007,
Quick fix for ithe 3007 issue that Aus and NZ players are experiencing- though Blizzard should really sort this out themselves - Changing your DNS to the google DNS server will allow you to log in to the game.

Players shouldn't need to do these things really.
MVP
Posts: 8,815
View profile
Got a thread going about this over on our ANZ forums:

http://us.battle.net/d3/en/forum/topic/7393109275

Seem's it could be related to DNS, which ISP DNS sever takes time to update.

If you want a fix now you can change your DNS to a public DNS like googles.
________________________________________________
Twitter: @Narull | ANZ Diablo III MVP
http://us.battle.net/d3/en/forum/topic/6490399005 - Narull's Hardcore Challenge.
There not spelling mistakes, Im speaking 'Ye Old English'
90 Tauren Warrior
5765
Posts: 3
Yeah, I'm getting the same error 3007 after i downloaded the patch. Also from Australia
I'm playing from "The Americas" region. As of 3:04 PM PST, I still cannot log into the game. It keeps telling me to patch the game, automatically exits, and the launcher just tells me the game is already up to date.

http://i.imgur.com/Aob4f.jpg

^Screenshot showing the message the game gives me after I enter my password.

EDIT: I tried the Repair option via the game launcher. Didn't work, the game keeps telling me to download a non-existent patch
Edited by LanceToTheN#1754 on 12/11/2012 3:09 PM PST
Another Australia, error 3007 here too.
As Narull said, change your DNS servers to a public one. And off you go, worked for me after getting 3007 all morning. Melbourne, Australia on Bigpond.
Oz player here, same thing
Australia here. I changed the DNS and it gave me load of errors as I am not only playing Diabolo. Even Diabolo doesn't work on those given settings. Way to go Blizzard. You guys needed 10+ hours to give us the finger?
Another bug I found is the language setting. I found the language setting is blank, so I clicked English as the option, and you know what, the system asked to quit the game and started downloading 2GB(YES, Two Giga Bytes) patch immediately without asking if I agreed to or not.

How stupid is that, and now I can't even cancel that patch downloading.

This game settings are definetely wrong in someway......................

Very disappointed to have this after 15 hours waiting to log in.
MVP
Posts: 8,815
View profile
Guys, checkout the sticky in the tech support forums: http://us.battle.net/d3/en/forum/topic/7392969288
________________________________________________
Twitter: @Narull | ANZ Diablo III MVP
http://us.battle.net/d3/en/forum/topic/6490399005 - Narull's Hardcore Challenge.
There not spelling mistakes, Im speaking 'Ye Old English'
same AUS 3007
Yeah the story goes like this, physical copies of d3 were region specific, there was a euro, asian and american region client. They could make more profit by shipping the asian client to Australia, despite knowing we would connect to the US region and it would cause huge conflicts everytime a patch was deployed (people couldnt play for hours) because of the update servers region mismatches.
maybe tommorow is ganna be better,because i too am getting this bug/error.I thought its because my comp etc.but then i openned the forums and saw some others guys getting the new patch bla bla bla,so hope for the best tommorow :D.
Blizzard should fix up an Oceanic server for Australian and new zealand Players :')
Thats true i just wanted to say that its not your problem its blizzard not patching asian and europian servers,just relax and hope for tomorow BTW im from europe and getting the same patch bla bla thingy. :D
make Diabolo 3 playable offline?
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]