Diablo® III

Error 3007 for Aus/NZ area users

(Locked)

Did the fix. Now the launcher says I'm up to date but the game tells me there's an update and restarts only to take me to a launcher that says I'm up to date.

I like playing this game. The real game, not the trying to play the game mini-game.
yeah i know not so good with comps tho haha but i got it working lol
MVP - Diablo III
Posts: 8,037
View profile
Did the fix. Now the launcher says I'm up to date but the game tells me there's an update and restarts only to take me to a launcher that says I'm up to date.

I like playing this game. The real game, not the trying to play the game mini-game.


Your connecting to the wrong region, go to Options-Account before logging in and make sure you are playing on The Americas.

EU and Asia servers are still having maint, so your client is a different version to them until they are patched.
________________________________________________
Twitter: @Narull | ANZ Diablo III MVP
http://us.battle.net/d3/en/forum/topic/6490399005 - Narull's Hardcore Challenge.
There not spelling mistakes, Im speaking 'Ye Old English'
We're currently looking into an issue AUS/NZ users are having when trying to connect to the US Diablo III servers. This thread will be updated when we have any additional information.

In the meantime, this workaround of changing to a free DNS provider is reported to be helping.

As posted in the Aus/NZ forums:

DNS settings are specified in the TCP/IP Properties window for the selected network connection.

Example: Changing DNS server settings on Microsoft Windows 7

Go the Control Panel.
Click Network and Internet, then Network and Sharing Center, and click Change adapter settings.
Select the connection for which you want to configure Google Public DNS. For example:
To change the settings for an Ethernet connection, right-click Local Area Connection, and click Properties.
To change the settings for a wireless connection, right-click Wireless Network Connection, and click Properties.
If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
Select the Networking tab. Under This connection uses the following items, select Internet Protocol Version 4 (TCP/IPv4) or Internet Protocol Version 6 (TCP/IPv6) and then click Properties.
Click Advanced and select the DNS tab. If there are any DNS server IP addresses listed there, write them down for future reference, and remove them from this window.
Click OK.
Select Use the following DNS server addresses. If there are any IP addresses listed in the Preferred DNS server or Alternate DNS server, write them down for future reference.
Replace those addresses with the IP addresses of the Google DNS servers:
For IPv4: 8.8.8.8 and/or 8.8.4.4.
For IPv6: 2001:4860:4860::8888 and/or 2001:4860:4860::8844
Restart the connection you selected in step 3.
'

i saw your mouth moving but i didnt understand aword you just said. Im on windows XP :/ your guys are hopless , i patch !@#$ all day long as a ceiling fixer at work and %^-* never goes wrong.. peoples ceilings always work no problems, sort it out blizzard.
Your connecting to the wrong region, go to Options-Account before logging in and make sure you are playing on The Americas.

EU and Asia servers are still having maint, so your client is a different version to them until they are patched.


It's set to the Americas.
If you change your DNS settings over following the instructions on the first page (assuming you have windows 7) then log into the game as usual (it will work).

You can then log out and change back to the old settings (ie the ones you changed from) and it will then work with your normal DNS settings. Who knows what has changed but clearly something has.
Bleeding player base daily.

This helps the cause.
Posts: 21
12/11/2012 03:45 PMPosted by Cyberwaste
Did the fix. Now the launcher says I'm up to date but the game tells me there's an update and restarts only to take me to a launcher that says I'm up to date.


this is the problem that im having aswell
85 Night Elf Rogue
5750
Posts: 18
12/11/2012 03:39 PMPosted by vandagar
It's a temporary workaround. You don't have to use it. No one is telling you you have to use a public DNS provider instead of your ISPs. You can wait until we've isolated and fixed the issue too, it's your choice.


If I can provide some more details. As the DNS server (in theory) only directs the IP address, I checked with in the other thread (and now tested myself) that the Google DNS was pointing people to the same IP as those who couldn't connect. So in theory the DNS server isn't the issue, but changing it is fixing something else.

Testing process:
Using the settings I had last night (ISP DNS) I was not able to connect this morning.

Setting the DNS to 8.8.8.8 I could connect

But then I reset my connection and went back to the orignal ISP DNS settings that I couldn't connect to earlier. I can now connect to D3 as per last night, with the settings that didn't work earlier. I have looked at Network Connection Details to verify that Windows is using the ISP DNS (assuming of course Windows is right).

So perhaps this refreshed the DNS in some way (or something else). But maybe this can help with isolating the problem.


This worked. it seems you download the patch threw the public dns and then reset everything back to the way it was and all is good.
Sky,

It's a temporary workaround. You don't have to use it. No one is telling you you have to use a public DNS provider instead of your ISPs. You can wait until we've isolated and fixed the issue too, it's your choice.


You sound irritated but imagine being in our shoes how we would feel. I can promise you we are feeling worse right now. We just want to play the game we bought and since this new patch we cant even log on unless I risk my hardcore hero dieing and being told it was my fault using some weird as hell public DNS. I'm not really a comp geek so I have no choice but to wait. I'm sure if you bought a game and they told you to use something other than your own ISP or you can just sit and wait till god knows when you'd be all 'You're kidding me right?'.

I applaud blizzards customer service since they always been nice to me and I know this isn't your fault but jesus this is ridiculous that we cant log on because of some tiny stupid patch.

Anyway that's my 20 cents. I hope this gets fixed soon...
THANK YOU!
It worked for me :)
TRANSLATE ME!
Installing Diablo III at "C:\Program Files (x86)\Diablo III\" on Wed Dec 12 08:02:40 2012.
Created file "C:\Program Files (x86)\Common Files\Blizzard Entertainment\Diablo III\Uninstall.xml".
Created file "C:\Program Files (x86)\Diablo III\Bnet\battle.net.dll".
Created file "C:\Program Files (x86)\Diablo III\Diablo III Launcher.exe".
Created file "C:\Program Files (x86)\Diablo III\Diablo III.exe".
Created file "C:\Program Files (x86)\Diablo III\fmodex.dll".
Created file "C:\Program Files (x86)\Diablo III\icudt49.dll".
Created file "C:\Program Files (x86)\Diablo III\icuin49.dll".
Created file "C:\Program Files (x86)\Diablo III\icuuc49.dll".
Created file "C:\Program Files (x86)\Diablo III\ijl15.dll".
Created file "C:\Program Files (x86)\Diablo III\InspectorReporter\BlizzardError.exe".
Created file "C:\Program Files (x86)\Diablo III\Logs\Blizzard Updater Log.html".
Created file "C:\Program Files (x86)\Diablo III\msvcp100.dll".
Created file "C:\Program Files (x86)\Diablo III\msvcr100.dll".
Deleted file "C:\Program Files (x86)\Diablo III\Updates\d3-0-13300-Win-final.MPQ".
The update was successful.

somewhere in here is the error 3007

because the previous version was working just fine
Edited by Delianeth#6880 on 12/11/2012 4:43 PM PST
Dear Incompetent Blizzard,

Your patch is stuffed, constant time outs and set to "The Americas", I connect to "Asia" and no issues so it is NOT a DNS issue.
Just fix the problem so we the PAYING customer that keep you in a job can play this B grade game.

Thank you, that is all.
thx

Just started a new character on Asia til they fix the Americas for us here in Australia.
Posts: 418
100 bucks says this issue wont be resolved for at least another 24 hrs.... and no, im not gonna stuff around with my settings so i can play, looks like im forced to wait this one out yet again... gg blizz, much appreciated.........
Edited by RocketShlong#1701 on 12/11/2012 4:58 PM PST
I just attempted to apply the fix option provided by "Omrakos" for wireless connection. However this did not provide any temporary solution to the 3007 error message I receive upon login attempt.could you please fix this issue asap.
Hi, I tried the work around but I still couldn't connect to the American servers. I hate it when the new patches are applied. Something always seems to go wrong. I haven't been able to play for ages and no telling how long this issue is going to take to get fixed. I Had a number of bids on items in the Auctions too. I bet I lost out there too.

Please fix this connection thing ASAP.
12/11/2012 03:39 PMPosted by vandagar
It's a temporary workaround. You don't have to use it. No one is telling you you have to use a public DNS provider instead of your ISPs. You can wait until we've isolated and fixed the issue too, it's your choice.


If I can provide some more details. As the DNS server (in theory) only directs the IP address, I checked with in the other thread (and now tested myself) that the Google DNS was pointing people to the same IP as those who couldn't connect. So in theory the DNS server isn't the issue, but changing it is fixing something else.

Testing process:
Using the settings I had last night (ISP DNS) I was not able to connect this morning.

Setting the DNS to 8.8.8.8 I could connect

But then I reset my connection and went back to the orignal ISP DNS settings that I couldn't connect to earlier. I can now connect to D3 as per last night, with the settings that didn't work earlier. I have looked at Network Connection Details to verify that Windows is using the ISP DNS (assuming of course Windows is right).

So perhaps this refreshed the DNS in some way (or something else). But maybe this can help with isolating the problem.


This worked like a charm.
All i did was make Preferred DNS - 8.8.8.8 then alternate DNS to 8.8.4.4
then i logged in. then i closed diablo.
then i went back to my original DNS settings.
then i logged in again. now im playing
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]