Diablo® III

How long is D3 expected to be supported on SL

This morning I learned that my pre-order of SC2: HotS won't run on my computer when it gets released, or possibly even in the beta that I am now included in due to the dropped support for 10.6 (http://us.battle.net/sc2/en/forum/topic/7415493419). On a whim I decided to browse the WoW Mac support forums as well, and I do come across a post that indicates that 10.6.x will no be supported moving forward for MoP and future expansions.

I am now left feeling that I am about to get !@#$-slapped with the next major update for D3 will also drop support for an OS that it was shipped on. Before we get all alarmist on this post, this is purely speculation as it will be the only game left of the three that will support 10.6.8 as a minimum version. I would like a straight answer on this, as to when we can expect to see a drop in OS support for this game as well. This wouldn't be a big deal if your titles weren't reliant on your servers to keep them patched and running.

I bought SC2 when it came out, and I pre-ordered HotS when that was available. Now I find I won't be able to play in march when the game comes out because you are completely dropping OS support for an OS that was indicated it would be able to run on. The feeling I take from this is that come 1.1 patch or the expansion pack to D3, I might not be able to play on my current computer anymore. What I would like is some actual transparency on this issue for both SC2 HotS and if this ever arises for Diablo 3. I have made a post in the thread I linked to asking about some clarification on this issue.

In addition, I think that as a community we shouldn't be blind-sided by these statements. Supporting these issues should not include linking players to purchasing an OS upgrade. The community as a whole should not have to change their computing environments because the devs want to drop code for an older OS that was fully supported when the game shipped when that code still runs fine now.
Reply Quote
Support Forum Agent
Hi DirkGently,

Blizzard will always support the two latest OS's for all games on the Mac platform. The details about this and how it relates to older OS's can be found on our Mac OS X Support article.

As far as older OS support, if an older OS will be dropped, we will provide notification, just like in StarCraft II now, and World of Warcraft when patch 5.0.4 (Mists of Pandaria pre-patch). When StarCraft II pre-sales were released, the system requires were released at the same time, which indicated 10.7 and above to play StarCraft II 2.0+.
Reply Quote
Hi DirkGently,

Blizzard will always support the two latest OS's for all games on the Mac platform. The details about this and how it relates to older OS's can be found on our [url="https://us.battle.net/support/en/article/mac-os-x-support"]Mac OS X Support[/url] article.

As far as older OS support, if an older OS will be dropped, we will provide notification, just like in StarCraft II now, and World of Warcraft when patch 5.0.4 (Mists of Pandaria pre-patch). When StarCraft II pre-sales were released, the system requires were released at the same time, which indicated 10.7 and above to play StarCraft II 2.0+.


OK, just addressing Diablo 3 then, I take it that there are no immediate plans to drop support for 10.6.8. I could understand this stance if this were a stand-alone product. However since we literally cannot play without the game servers, giving us notification as to when support may or may-not be dropped is nothing more than spitting in our faces. Granted there is not much more you can say other than directing us to the upgrade process from apple. What happens when our hardware isn't supported on that patch or we need to run software that won't work on new versions of the OS. This basically locks us out by saying "drop a few hundred to a few grand on a new computer and suck it up".

I really love this game, I don't want to be forced into a position where I cannot play this game because of an arbitrary drop in OS support. There are tools i use every day which I cannot replace so I can run 10.7 or 10.8. This makes upgrading not an option for me unless I am going to buy a brand new computer for these game. If the decision is made to upgrade parts of the game that would limit the OS requirements, then I think a serious assessment should be made as to what is necessary and how it could be done to be the least invasive and disruptive way possible given "oh just upgrade" isn't an option for everyone.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]