Diablo® III

Trouble logging in (Error 500, 3006)

I've been having constant connection issues, usually at the authenticating stage. I've tried connecting on both a wireless and wired connection to no difference. I might be able to get on one out of every 10 tries, although my ping is usually in the red when I finally get there. I've played on my laptop at a friends house with no issue, so it seems to be a connection thing, however according to speedtest.net I've got a sub 50 ping, 10 mbps download, and 1 upload which should be fine...
Reply Quote
MVP - Technical Support
90 Draenei Mage
6490
Try switching to Google Open DNS :

https://developers.google.com/speed/public-dns/docs/using

And flushing the DNS cache :

From Applications ->Utilities open Terminal

Copy and paste in these lines and press return after pasting each one in :

sudo killall -HUP mDNSResponder
sudo killall mDNSResponder
sudo dscacheutil -flushcache

You may need to put in your admin user password for each.
Reply Quote
I've flushed dns multiple times to no avail. I also switched to googles open DNS but it doesn't seem to have any effect either. Any idea why my latency would be so low (i'd kill for a yellow bar) all the time even at dead hours? I used to be able to play no problem if it was late at night, but lately even that doesn't seem to help.
Reply Quote
Got a new error:

There was a problem with the authentication module (error 1702063727).
Reply Quote
Like me?
Can you log back in if you force quit the game?
I have zero connection issues, I can login 100% of the time
except only when I log out and try to log back in
http://us.battle.net/d3/en/forum/topic/7379037850
Reply Quote
Support Forum Agent
The auth module error is referring to downloading the module into /Users/Shared/Blizzard folder.

Sometimes this is due to corruption, and other times this is due to a network issue prior to the connection getting to us.

What happens when you create a new admin on your account and try to login the game with that one?
Reply Quote
The auth module error is referring to downloading the module into /Users/Shared/Blizzard folder.

Sometimes this is due to corruption, and other times this is due to a network issue prior to the connection getting to us.

What happens when you create a new admin on your account and try to login the game with that one?


I have tried all of the suggestions listed above but have had no luck whatsoever. I even created a new admin account and tried logging in and still had no luck.
Reply Quote
Support Forum Agent
What specific error codes are you seeing when you attempt to login?
Reply Quote
Tried the above and it didn't work. Still getting 3006 errors, with the occasional 500. I never get through on the first try, and like a poster above said any subsequent tries take significantly longer to get past the authentication stage (this is true if I dc or am just trying to log on the first time). Reopening diablo gets past authentication quicker, but I still don't usually get on. The loading screen that occurs after you select a hero and resume game is getting stuck too it seems for me.
Reply Quote
And now I'm in game, but unable to do anything with a ping of 0. I can talk in general chat just fine though, so I don't know what that's about.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]