Diablo® III

Extreme lag and constant disconnects, 3007 +

Just started happening today, a few hours earlier is when I first tried to log. I disconnect about a minute or so into checking the auction house.

So I create a game and notice I have very high latency, although my internet appears to be fine elsewhere during the loss of connections.

Anyone else experiencing non stop disconnect or latency?
Reply Quote
same here, just started about half an hour ago for me. its not just error 3007 for me tho im getting network disconnect, failed to find party !@#$, failed to load hero data crap...super high latency and just plain straight to menu disconnect. What i found weird was one time when i got disconnected i restarted my diablo and when i logged into lobby it sent me straight to the game that i was in...without an invitation or resume game.

I hopped on my other games and had no problems, the usual low latency.
Reply Quote
I'm also getting ridiculous disconnects, error 3006's, i got removed from my own game. Seems to work if i exit diablo and reload but it's beyond annoying. I've been disconnected several times in the past hour. I hope they fix this soon.
Reply Quote
It's actually happening for me on both WoW and Diablo 3 - is it a battlenet thing?
Reply Quote
Posts: 137
Happening to me frequently as well.
Reply Quote
same here, AUS
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]