Diablo® III

Frequent Network Disconnects booted from game

As the title says, I've been experiencing an insane number of DC's from in game, at least once an hour. This has NEVER been a problem before...Like most problems I've had with this game none of my hardware has changed, all drivers are current, and my router(s) are performing normally.

I also do not lose connection to battle net, it shows me as online to friends, and I still receive any messages they have sent me. It simply pops up the box in game and boots me to char screen.

My computer DOES NOT lose connection from the internet randomly, nor does any device I have running in my house...

Any suggestions?

EDIT::: If a blue decides to read this post by some small miracle, I've already done the "fix" for rubberbanding involving disabling the offload options (which worked brilliantly btw), and that was months ago. This is a NEW problem.
Edited by runit3#1931 on 1/28/2013 2:53 PM PST
Reply Quote
same thing has been happening to me as well, only noticed this past 2 weeks now, and only when playing d3 do i loose my internet connection and it is wired.

same symptoms as above poster, please look into this CM's!

cheers
Reply Quote
Same here, not sure what it is came outa nowhere
Reply Quote
same here
Reply Quote
Me to. I just get a message telling me I'm kicked out of the game. This is particularly frustrating, as I'm on a pretty difficult quest or in the middle of a battle when it happens. So I have to start over. I have no issues with my connection, no one else in the house is losing theirs.
Blizzard... please fix this!
Reply Quote
bump
Reply Quote
bump
Reply Quote
I get something similar.. but it boots me directly to desktop saying something about D3 having a problem running... it only boots me if I am in game... nothing happens if I am in main menu... just started happening a couple of days ago.... anyone can help?
Reply Quote
blue plz...
Reply Quote
same same......
Its not a America server only prob is it?
Reply Quote
same same......
Its not a America server only prob is it?


Don't know, although I haven't gotten one today after the server restart. Haven't really played for more than an hr straight. Guess I'll give it a go now.
Reply Quote
I just got kicked out. Said "temporary outage of the battle.net service.."
Reply Quote
85 Human Death Knight
0
Same here, error 73, temp outage.
Reply Quote
since the 1st of the year... atleast once an hour on the hour... HORRIBLE. daily.... never happened before either. meh
Reply Quote
Experiencing the same issue here: http://i.imgur.com/zvW7b.jpg. Getting booted to the character screen, I don't have to re-login after that to start a new game. The shortest time between disconnects was about 6 minutes for me, the longest - about 1 hour.

I tried running World of Warcraft in parallel and at the time of disconnect in Diablo WoW was working fine with my usual latency (50-70ms both home and world).

I tried disabling antivirus, firewall and resetting router. None of that helped. I do not think this problem is on my side...

Edit: Tried running different acts, same problem: http://i.imgur.com/bgL9M.jpg. Note the time difference between the 2 screenshots, its only 11 minutes (half of which I was writing this message on the forum).
Edited by Umo#2283 on 1/7/2013 12:56 AM PST
Reply Quote
The situation is a bit worse today: i get disconnects 30 seconds - 5 minutes into games... I guess I'll play WoW until this problem gets fixed.
Reply Quote
Yep. Problem is going strong again today. There was a break in the DC's yesterday, this is getting ridiculous.
Reply Quote
Yeah our Household is having serious DC's between 20 seconds and every few mins. our ISP is fine, our Router is fine, we can load other online games, (World of Tanks, RaiderZ and Planetside 2 work fine) and happily browse the net.

Anyone that can explain or have a fix please let us know, We are in New Zealand if that helps.
Reply Quote
Same here, Noticed especially after last patch. D3 is THE ONLY!!! program of about a hundred that does this, so it must be a BLIZZARD SERVER issue RIGHT?
PLEASE help I have been playing since D1, LOVE the game but this SUCKS

Me to. I just get a message telling me I'm kicked out of the game. This is particularly frustrating, as I'm on a pretty difficult quest or in the middle of a battle when it happens. So I have to start over. I have no issues with my connection, no one else in the house is losing theirs.
Blizzard... please fix this!
Reply Quote
Come on Blizzard wake up!!!. More than 2 weeks to fix this problem? You got to be kidding me right for a company of your size to take this long to fix on going problem like this and error 3006?. Is everyone still on Xmas and New Year mode or something?. Keep quiet and not doing anything won't solve the problem you know?. I hope the RMAH goes down hill so that you guys would actually notice what the heck is going on. Really sad to see this game is getting worst by the day.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]